Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 11.10 x86-64 in Virtual Box. While shutting down the last time the system ran normally, it seemed to have hung up, so I just killed the system. When I wanted to boot it again, nothing happened. If I go to recovery mode in GRUB I get following information:

VFS: Cannot open root device "UUID=99532d26-eb6b-43bf-8520-916a85d6a69d" in unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
0b00         1048575 sr0  driver: sr
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Pid: 1, comm:swapper Not tainted 3.0.0-19-generic #33-Ubuntu

As I read in several other boards it seems that GRUB can't find '/'. So I booted from the (virtual) Live-CD and did the following:

sudo mount /dev/sda1 /mnt #according to `sudo fdisk -l` sda1 is my booting partition
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo chroot /mnt
cp -r /usr/lib/x86_64-linux-gnu/pango /usr/lib
update-initramfs -u -k 3.0.0-12-generic
update-grub2 #does not seem to work: Cannot find list of partitions!  (Try mounting /sys.)

Then I rebooted, chose the non-recover entry and nothing happened again. I did this like 3 times and it was the same always.

Hopefully somebody can help me. Thanks in advance!

share|improve this question
up vote 2 down vote accepted

Here is the solution to my own question: Somehow uname gave me a wrong name (3.0.0-12-generic), but according to GRUB it's 3.0.0-19-generic. Executing update-initramfs -u -k 3.0.0-19-generic and rebooting made it work!

share|improve this answer

Also read here: [Kernel Panics][1]

After reading the answers on the above post which explains what is going on, try using the [Boot-Reapir CD][1][1]:

Worked great at repairing the "the device is misidentified in your root= parameter (cases 2, 3)".

this answer[1]: Kernel panics with "Cannot open root device" error, where do I append the "root=" option?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.