Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Is there a way to speed up the Dash? When I press the super key for the first time it can take ~2 seconds for the dash to appear. Whereas if I use Synapse, it will appear instantly.

share|improve this question

6 Answers 6

Ubuntu 12.10


I. Install Unsettings. Type in terminal

sudo add-apt-repository ppa:diesch/testing

sudo apt-get update

sudo apt-get install unsettings

Open Unsettings. You can try 2 changes.

  • First, go to Dash > Blur and select No blur.

No blur

  • Second, go to Themes and change Graphics Mode to Force low graphics mode.

Low graphics mode

II. Install the Compiz Config Settings Manager. Type in terminal

sudo apt-get update

sudo apt-get install compizconfig-settings-manager

Open the compiz manager. Go to OpenGL and select Texture Filter > Fast

Texture filter

Remember to log out!

share|improve this answer
    
"changing Graphics Mode to Force low graphics mode." is not available in 12.04 Unsettings 0.08 –  lefterav Apr 12 '13 at 12:19
    
Doesn't work for 13.10 - I guess there's no saucy branch. –  Robin Winslow Mar 14 '14 at 14:35
1  
also doesn't install for 14.04 –  KasiyA Sep 7 '14 at 10:52
    
It's much faster after setting no blur, thanks. –  MarkZar Jun 6 at 12:15

Deactivating the "blur" effect might help.

To do so install "MyUnity" in the Ubuntu Software Center. Then you can disable the blur effect by setting the "Blur" option on the "dash"-tab to "Off".

Here's a screenshot: window screenshot showing disabling of blur effect

share|improve this answer
    
Thanks it improves slightly. Does changing the swapiness factor can have an effect? –  user72126 Jun 26 '12 at 23:20
7  
2  
You can switch off dash blur in compizconfig-settings-manager too. –  popey Jan 3 '13 at 4:11

Ubuntu 12.04LTS

Unity Dash in Ubuntu 12.04LTS (Unity 5) may lack the swiftness and fluidity of later Unity versions like Ubuntu 14.04LTS's Unity 7, but it's stable enough for everyday use. Before you try the steps for improving Unity's speed, it's recommended to update Unity and Compiz to their latest versions available on Ubuntu 12.04LTS's repositories. This is because initial versions of Unity 5 had stability problems, but later ones received stability and speed improvements backported from successive Ubuntu releases. By the time final release of Ubuntu 12.04LTS (12.04.5) was out, Unity (v5.20) had gotten quite solid and stable.

Some of the steps suggested here require Compiz Config. You can also use other tools like MyUnity, Unsettings, Ubuntu Tweak or editing the schema/settings directly through dconf-editor or gsettings. But, I recommend Compiz Config, coz it allows you to edit all Compiz and Unity settings in one place. Click here to install Compiz Config Install Compiz Config

Compiz Config Unity Plugin Settings Experimental Tab

Step 1: Deactivate Dynamic Blur: This would reduce lag and stutter experienced when using Dash. Open Compiz Config -> Ubuntu Unity Plugin -> Experimental Tab -> Dash Blur and change it to Static Blur or No Blur.

  • Static Blur causes a flicker bug with some graphics drivers in Ubuntu 12.04LTS. Otherwise, this would've been the best choice.
  • No Blur makes Dash transparent. As a result, you may need to increase the opacity or darkness of the Dash to improve visibility. This can be done by changing the color value in Compiz Config -> Ubuntu Unity Plugin -> Experimental Tab -> Background Color option.

Step 2: Remove unwanted Lens and Scopes: The Dash in Ubuntu 14.04LTS provides an option to disable/enable Scopes. Unfortunately, this feature isn't available in 12.04LTS's Unity. However, they can still be manually disabled by editing each individual lens' setting under dconf-editor->desktop->unity->lenses. But, I prefer to remove the unwanted Lens and Scopes altogether.

  • Uninstall unity-scope-musicstores and unity-scope-video-remote. If your Ubuntu machine isn't connected to internet very often or if you don't need these services, just remove them.

  • Uninstall unity-lens-music and unity-lens-video The File Lens can still show all your music and videos, and filter them too. You don't need those lenses unless you're a real big music or video lover.

Step 3: Reduce Dash Startup Delay: You might have noticed that Dash takes a long time to load when used for the first time after booting. This startup delay can be reduced by using preload or similar daemons. Click here to install preload Install Compiz Config

Step 4: Reduce Graphics Settings: If all the previous steps didn't improve speed noticeably, or if you are still hungry for more performance, reduce the Graphics Settings for Compiz. I got this idea from Ed Villegas' Answer for Ubuntu 12.10. But remember, this change affects graphics quality of the entire Ubuntu system, not just Unity alone! Open Compiz Config->OpenGL->Texture Filter and set it to Fast.

Reduce Compiz Graphics Settings Level

After doing all the above restart the system before checking the results, or else Unity may behave abnormally.

Note that Ubuntu 12.04LTS's Unity 5 doesn't have a Low Graphics Mode like that of Unity 7 on Ubuntu 14.04LTS. However, 12.04LTS provides a similar looking but very different Unity2D desktop, which runs on a different Window Manager instead of Compiz. You may use it if your graphics hardware is very weak. But, I wouldn't recommend using it under normal cases.

share|improve this answer

There may not be anything to do for that.

If the Dash hasn't been used for a while, it is possible its code has been evicted from memory to make room for something else used recently. If that is the case it has to grab that back from disk before it is able to act.

Again, there may not be a workaround that would solve it without adding some other slowdown because of memory usage manipulation.

share|improve this answer
2  
No, this is not the problem. Even on high-end systems with copious amounts of RAM, and even when used continuously, the dash is slow, and that's primarily due to animations done in a lame way. –  Dan Dascalescu Dec 30 '12 at 12:47
    
Actually that is the problem for some people. My system is a core i7 with loads of RAM, but when the backup kicks in the cache is used up and apps get pushed out from the cache. Pressing the Super key (which I don't do often) causes it to page in the necessary memory and that introduces a delay. –  popey Jan 3 '13 at 4:12

The dash is slow due to the extra high end graphics which your graphics card supports with much difficulty. Add the following line to the .xprofile file in your home directory.(In case its not present the create it).

export UNITY_LOW_GFX_MODE=1

The above line will enable low graphics mode which can be easily supported by your GPU. Dont worry you will not loose any image quality in case you are fearing so :)

And save it and logoff and login again. And now check. Your Dash home would work fast and smooth.

share|improve this answer
2  
Nope. very little improvement, if any. Typing in dash is still laggy and dash still takes ~2 secs to pop up. Plus it's buggy, I have the launcher on autohide, and doing what you say leaves a black line all the way down the screen where the edge of the launcher is supposed to be. –  BullfrogBlues Jan 3 '13 at 18:15

There are at least two bugs reported for this long-standing problem (goes back to 2012). Please consider adding yourselves to the bugs to bump the matter as there seems not to be much attention paid to it from the developers:

https://bugs.launchpad.net/bugs/814833

https://bugs.launchpad.net/bugs/919801

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.