Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have kind of an odd problem. The time in my Unity bar is right, but the time in bash is 2 hours ahead.

$ date
Wed Jun 20 15:31:55 CDT 2012

Unity bar:

Wed Jun 20 13:31:55

Here are my etc configs:

$ cat /etc/timezone
America/Los_Angeles

locale:

$ locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Finally, I tried $ sudo dpkg-reconfigure tzdata and setting it to "Los_Angeles".

Has anyone seen anything like this?

EDIT

So I installed Ubuntu on another computer and after I installed updates using dist-upgrate, it was 2 hours ahead again... On a completely new computer. Here is the output from apt: http://pastebin.com/jMffJNs4

share|improve this question
    
Is your BIOS clock set to UTC or local time? If it's UTC, /etc/default/rcS should have a line UTC=yes, otherwise UTC=no. –  elmicha Jun 20 '12 at 21:36
1  
@elmicha My bios is set to UTC and UTC=yes is set in /etc/default/rcS and it's still using the CDT timezone in bash. –  Kyle Jun 21 '12 at 17:40

1 Answer 1

up vote 1 down vote accepted

This was all my fault.

It was a local TZ var on the profile level being sourced that was hard to find.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.