Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When using ubuntu (12.04, both installed and on a live usb) I get a lot of these messages:

pciehp 0000:00:1c.5:pcie04: Card not present on Slot(37)
pciehp 0000:00:1c.5:pcie04: Card present on Slot(37)

And with a lot I mean about 20 per second. This has a crippling effect, and I would like to get rid of it :)

The computer is a packard bell easynote BG48-U-100 DC.

I tip I picked up from some fedora/redhat error here was to look at lspci -vnn. I have pasted the part about "00:1c.5" here: http://pastebin.com/0sfsiqW2 For what good it may do, here is the lsmod of my machine: http://pastebin.com/DQZy1kAL

From that first pastebin I think to conclude that it has to do with the module shpchp, which seems to me (aka: google) to have something to do with ACPI. That's as far as I've come in disecting this.

Can anyone help me along further? What can I do, check etc?

I did see this topic but my intentions are not to surpress the error message: I know how to do this (from that topic ;) ), but I'm looking for a real sollution.

Finding the problem on the internet does suspect me to believe it is neither an ubuntu specific nor a packard-bell specific problem.If you google the problem it seems that is present on several other distribution/hardware combo's as well, and it looks like the advice is to remove one of the drivers? I have no clue as to which driver I should look at and and what would be the effect of just removing it.

I have seen this topic which is old-ish, but describes my problem and is about a similar computer. The solution in this topic was to compile a new kernel using a spanish guide, which seems a bit extreme to me, so I'm kinda hoping for a better solution than that.

edit: I just tested on 12.10 which still has the problem

On the account of surpressing: I can surpress it in the syslog, but the IO still goes on. I do also see the mentions in dmesg, and in one of the consoles. Even a way to surpress all these things would be a help at this point.

Another test also shows that a quick Fedora boot has the same issues on this machine

share|improve this question
    
perhaps you can explain what is the "crippling effect". Also, does removing the pciehp kernel model fix your issue? sudo modprobe -r pciehp –  fossfreedom Oct 31 '12 at 9:34
    
Well, there is so much IO going on that everything is too slow to handle. Especially during install / live mode from USB. I don't think I can remove pciehp as it's compiled into the kernel, can I? –  Nanne Oct 31 '12 at 9:44
    
absolutely no idea if its critical to your laptop - if you can wait until boot up and try it - it will either work or not (it is not permanent). To make it permanent you will need to blacklist the kernel module (wiki.debian.org/KernelModuleBlacklisting) - anyway - this is not really my forte, so good luck. Given your research, looks like if you know what to change, compiling a kernel may be your only choice. –  fossfreedom Oct 31 '12 at 9:50
    
I'm quite sure it's not really possible to unload pciehp as it is compiled into the kernel -> unless I'm mistaken you can only unload "modules" (non-compiled-into-kernel). Trying to use modprobe therefore didn't work. Blacklisting has the same issue sadly. –  Nanne Oct 31 '12 at 20:51

3 Answers 3

up vote 0 down vote accepted

I tried the following patch-methods, and listed why they didn't work for me:

  • Bios features: nothing I could do in the bios would effect the hotplug problems I have.
  • Suppressing errors. The blacklist didn't reliably work for some reason (I might have done something wrong, I admit) and as I said, it isn't a real sollution. The polling still would've been going on. Apart from that, the messages would also show up in the tty's, in the DMESG, etc.
  • Unloading modules: the modules were compiled into the kernel, so blacklisting or unloading those doesn't work.

In the end I did compile my own kernel, using this manual:

https://help.ubuntu.com/community/Kernel/Compile

and specifically the "alternative" method. There is no need for all the fancy different flavors if you just need to remove one thing, so I copied my old config (as explained), removed the hotplug stuff, and waited for the compile to complete.

share|improve this answer

For what its worth, On an Asrock ion 3d (with Ubuntu 14.04 now) disabling usb3 in BIOS solves the problem.

Pciehp flooding dmesg ("card nog present") no longer occurs.

share|improve this answer

Hit up the bios and disable your Power features. Cool N quiet/powernow and or whatever intel has.

Look for pcix powerstate features as well. Cause it does sound like a hotplug issue, that will at least troubleshoot that.

share|improve this answer
    
I'm not really sure that would help the hotplug issues? Anyway, the only "power" related bios-setting is LCD dimming. No sollotion sadly :( –  Nanne Oct 31 '12 at 20:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.