Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I disabled my Synaptics touchpad while a key on my keyboard and now I can't get it to work again. When I press that key again it says the touchpad turns back on but will not work at all. Rebooting doesn't help, and I tried installing touchpad-indicator but when I try to enable from there it says that it enables, but the icon remains like it's disabled. The odd thing is that it works on the lock screen so I know the drivers aren't messed up, it's just a setting.

Also, the touchpad works on guest mode but still nothing on my account. I tried using gconf to set the touchpad_enable to true and it worked, it sure set it. Doesn't make a difference though, my touchpad is still useless.

Terminal commands I've used:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

synclient Touchpadoff=0  

and:

modprobe psmouse
share|improve this question

2 Answers 2

I just had this same problem, my solution was: (if you are a newbie memorize it and then do it).

  1. Go to a tty by pressing Ctrl+Alt+F1
  2. Press your Touchpad's enable-disable key: (in my case) Fn+F7
  3. Switch back to X by pressing Ctrl+Alt+F7

    (If your Touchpad wasn't re-enabled, press again your Touchpad enable-disable key: Fn+F7)

Before I found this I had tried everything out there but couldn't get it to work until I noticed the button (Fn+F7) used by Ubuntu to enable-disable the Touchpad was the same my laptop's hardware uses, so the issue wasn't that Linux didn't enable the Touchpad, it was that I had two systems (Linux and hardware) enabling and disabling my Touchpad for some reason, they were out of phase, when one enabled, the other disabled. (You can actually make this happen by running my solution again).

share|improve this answer

On 11.10 the laptop touchpad sometimes stopped working after a little while. I resolved it by opening a terminal and using the following command :

synclient Touchpadoff=0

Not sure if it will help or solve your problem, but it's worth trying. :o)

share|improve this answer
    
Thanks, tried this but it didn't work sadly. –  user71607 Jun 20 '12 at 19:58
    
Sorry not to be of more help, hopefully someone will have a solution. –  Fernhill Linux Project Jun 20 '12 at 20:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.