Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

After trying to connect to a wired network, then unplugging the wired network and putting it to sleep, upon wakeup the wireless stopped working. Even the network manager has the wireless option greyed out, and when I go into the network settings, it won't allow me to turn it on. Toggling the wireless F2 switch does nothing. Doing an rfkill unblock all does nothing and sometimes won't give me a new command line. I've tried rebooting several times, and rebooting with earlier updates of Ubuntu.

I'm running Ubuntu 11.10 on a Dell Inspiron mini 1018

Network controller: Realtek semiconductor, RTL8188CE

rfKill list shows:

1. dell-wifi: Wireless LAN
   Soft blocked: Yes
   Hard blocked: Yes   
3. phy0: Wireless LAN
   Soft blocked: No
   Hard blocked: Yes

lshw shows: ethernet working fine, but wireless interface as DISABLED.

a search for the drivers shows everything installed and detected.

I can't figure out what to do in this. Any help is hugely appreciated.

share|improve this question
In the first paragraph, the "doing an does nothing" should read "doing an rfkill unblock all does nothing." Sorry, it deleted my brackets! – saint facetious Jun 20 '12 at 19:22
Do you have any restricted drivers available to you? – darryn.ten Jun 21 '12 at 12:38

1 Answer 1

I had the same problem with my Dell Inspiron 3000, which has the same wifi card by Realtek. (Windows users are complaining of the same problem!)

I clicked on the wifi networking button on the top right of the screen, and then clicked edit and selected my connection. Then select the ipv6 network tab and select ignore from the method drop-down menu.

Then I ran the following line in the terminal:

echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

Reboot and it worked like magic.

It took me 3 days to figure it out, but now my internet connection is stable :)

share|improve this answer
That is a wrong solution for OP's adapter. It is quite different. And the problem is in dell_wmi. – Pilot6 Oct 31 at 9:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.