Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've a problem with Javascript on web browsers. I can't open Facebook, I tried to delete cookies and cache, and thanks to this I manage to login and see the home page, but then whatever I do it will hang up loading and finally get 324 error (empty response). Maybe I found the culprit in the Javascript because when I tried to deactivate it I finally managed to use Facebook but chat timeline doesn't work and loading time sucks. It happens both on Chromium and Firefox browsers but it doesn't happens on the same computer with Windows 7. Tried to uninstall openjdk7 and install oracle java 7 but nothing changed. How to solve it?


I've already tried to disable all add-ons (I don't use Greasemonkey) but nothing changed, I manage to use Facebook only when I disable JavaScript from the settings, and in that case both chat and timeline don't work, and page load times are very long. I can't believe there's no solution to this problem, the weird thing is that it happened suddenly, maybe due to buggy updates, I absolutely don't know. The only thing I discovered is that is that JavaScript is to blame.

share|improve this question
2  
javascript has nothing to do with java from oracle.. (jdk/java 7).. disable all addins and check. Disable all custom JS file if you are using like greasemonkey script to customize fb chat, fb photozoom –  Web-E Jun 20 '12 at 17:38

1 Answer 1

It's not a JavaScript problem. I found in Internet a solution that worked for me by setting the MTU value to 1402 and the DNS primary to 8.8.8.8 and the secondary to 8.8.4.4.

share|improve this answer
    
Would you like to explain what those DNS's are. (For those who don't know) –  Mateo_ Oct 5 '12 at 1:01
    
Please be aware that DNS Servers route your requests. They could do harm by routing to malware. Only use DNS servers from ISPs you fully trust. Seems to be an odd routing problem, not really ubuntu related, but more general. –  mondjunge Nov 14 '13 at 11:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.