Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from Ubuntu 11.10 to 12.04. My Samson C01U USB microphone, which has worked for many years on Ubuntu, now is having problems.

The symptom is as follows. After a reboot, the microphone works as expected. Recording with Audacity is fine. Then, after some indeterminate amount of time, the microphone disappears from the system. That is, it is no longer listed in pavucontrol or alsamixer. Unplugging and re-plugging the microphone does not resolve the problem. Occasionally, the microphone will appear in pavucontrol for an instant on re-plug, but disappear immediately.

I have disabled PulseAudio and observed the same behavior. (That is, the microphone works fine, then after some time is no longer a valid "card" in alsamixer.)

The only relevant-looking line in the syslog is as follows. The timing correlates to the disappearance of the microphone, and the USB device number is that of the microphone.

kernel: [63194.088077] usb 2-4: reset full-speed USB device number 12 using ohci_hcd

share|improve this question
add comment

1 Answer

Well, I suppose in a way I have solved my own problem. That is, I wiped my Ubuntu install and installed a fresh 12.04 instance, and now the problem is gone. I still have the exact same home directory, so presumably it wasn't a user configuration problem.

So apparently the issue was somehow a result of the upgrade. I hate to have wiped out the problem without finding the cause, but I needed my microphone!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.