Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Guys I am trying to send a file from my Galaxy s2 to ubuntu but its keep dropping the connection but im able to send a file from Ubuntu to Mobile .

I have seen this link Botskool.com and its mentioned there is a Receive Files option in BT Preferences. But in my BT settings its no where to be seen.

enter image description here

Help

share|improve this question
    
Waiting for some good response –  OmiPenguin Jun 21 '12 at 13:47
    
Samik's answer is correct. Please accept it. –  Geoffrey Jul 11 '12 at 20:26
    
ok I accept that but is it possible that whenever i share a file over bluetooth it should prompt me for some password because any one can send me a file without pairing which can be a malicious file. **And what package do I need to enable it ** –  OmiPenguin Jul 12 '12 at 13:01
    
there is a setting for only receiving files from paired (set up) devices. –  Geoffrey Jul 13 '12 at 2:28
    
Seriously, the answer to go to Personal File Sharing Preferences (type "share" in the search bar at dash home) is the right answer. Works great now! –  user140109 Mar 14 '13 at 0:40

1 Answer 1

up vote 12 down vote accepted

There isn't really any receive option. Go to Personal File Sharing Preferences and select Always under Accept File: option if you want to receive files from your device without pairing it, though I'd recommend pairing as if you select this option any device can send malicious/bogus files to your computer without pairing while visible.

Here is a screen-shot of Personal File Sharing preferences

share|improve this answer
1  
this menu needs to pop up when you first start with Bluetooth –  Tim McNamara Nov 4 '12 at 4:30
    
Additionally, there should be a button in the bluetooth settings dialog which can be clicked to make the personal file sharing preferences dialog box appear. Are there bug-reports along these lines? –  Mark Apr 19 '13 at 13:58
    
In case you still can't receive files even after enabling "Receive files...", check that /usr/lib/gnome-user-share/gnome-user-share is running. It is started automatically upon login by /etc/xdg/autostart/gnome-user-share.desktop if file sharing is enabled, however there appears to be a bug (at least in 13.10) that prevents gnome-user-share from starting when enabled in preferences. –  Roman Jan 19 at 15:54
    
@Roman I confirm that this bug is present in my Ubuntu 13.10 –  PHP Learner Feb 23 at 11:17
    
I just can't understand why it is not a default option in Ubuntu to accept files from devices that I manually set up...it really took me some time to find this answer and I installed and reinstalled dozens of times blueman and others... –  Joschi Jun 11 at 8:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.