Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a macbook 8.1 with ubuntu 12.04 installed. But my cpu is getting very hot. On Mac my CPU is 50-60°C warm. But on ubuntu my mac is getting very hot and is by about 60°C but with min 3000rpm instead of 2000 on mac and the fan is getting very loud with 4500rpm on ubuntu when im browsing (without flash) or doing something else. i set it to 3000rpm because it is not getting so noisy instead of 2000rpm minimum.

But thats not that what im expected.

What ive done:

i installed lm-sensors to see the temperatures and started the sensors-detect

i installed macfancld, jupiter, the newest drivers from x-updates and installed the i965-va-driver

oh and i installed mesa - with the default version my sandbridge was displayed as unknown

i added GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force drm.vblankoffdelay=1 pcie_aspm=force drm.vblankoffdelay=1 i915.semaphores=1 i915.i915_enable_rc6=1 i915.i915_enable_fbc=1"

ive added rfkill block bluetooth to /etc/rc.local to switch of bluetooth by default on boot

my mac is not as noisy as before but it is noisy and sometimes very hot

i hope you can help me

share|improve this question
add comment

3 Answers 3

To make this work, I have to boot my mac with efi .

My solution was based on EFI-Booting Ubuntu on a Mac.

The writer there says that you have 2 grub files on your efi partition but there should only be one (grubx64.efi) .

The mac is now 5-10°C cooler and the startup is now very short .

share|improve this answer
add comment

Do you have a 13" or 15" Macbook? 15" Macbooks from the past few years come with both a discrete and integrated graphics card. When dual-booting my 15" Macbook 7,2 I had issues of overheating because Ubuntu would use both my discrete and integrated graphics card. To solve my overheating problem I had to EFI boot (see Timse201's response) and disable my discrete graphics card upon boot, using Grub2. This page provides steps for disabling the discrete graphics card. See ubuntu documentation for more information specific to your Macbook model.

share|improve this answer
add comment

Although these answers, macfanctld etc may be relevant to some people. I realized that the solution for me was that my video card didn't have the proper drivers installed. After installing the AMD specific drivers, my Macbook Pro ran considerably cooler (50%). So if your a newbie to Ubuntu and you have a Macbook Pro with a AMD ATI videocard follow these instructions to install the correct drivers and your computer should run a lot cooler.

https://help.ubuntu.com/community/BinaryDriverHowto/AMD

I installed the drivers using the Additional Drivers method. Additional Drivers can be installed though the Software Center. This made the install pretty much automatic.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.