Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to add Facebook account in Gwibber, It gives the following error:

**Unable to load page**

Problem occurred while loading the URL https://graph.facebook.com/oauth/authorize?scope=publish_stream%2Cread_stream%2Cstatus_update%2Coffline_access%2Cuser_photos%2Cfriends_photos&redirect_uri=http%3A%2F%2Fwww.facebook.com%2Fconnect%2Flogin_success.html&type=user_agent&display=popup&client_id=71b85c6d8cb5bbb9f1a3f8bbdcdd4b05

**Cannot resolve proxy hostname ()**

How can I fix it?

share|improve this question

4 Answers 4

I got your problem now. Try this few steps:

  1. Go to Home folder, then show all hidden files using Ctrl+H.
  2. Browse to .config/gwibber.
  3. Delete gwibber.sqlite.
  4. Now try to connect your Facebook.
share|improve this answer
    
Yes My internet is working very well. I even Authorized Twitter successfully. The only problem is in Facebook Authorization. Could you please help me out in fixing Proxy setting? –  Ashish Jun 20 '12 at 15:10
    
@Ashish I see. I updated my answer. Does it work? –  audrianore Jun 20 '12 at 16:16
    
Done. But it Didn't helped. And Bytheway I just removed the twitter account and tried authorizing again and found the same problem in that as well. –  Ashish Jun 20 '12 at 17:09
    
Really? Did you try updating your software? Or re-install Gwibber? –  audrianore Jun 20 '12 at 17:12
    
I did tried Updating it and even tried installing it without pluggins because I somewhere read that "telepathy-butterfly" creates problem. But nothing is working out –  Ashish Jun 20 '12 at 17:18

I found the answer here: http://ubuntuguide.net/ubuntu-tip-12-04-midori-epiphany-cannot-resolve-proxy-hostname-problem

Here is the important part:

Head to System Settings -> Network, in Network Proxy tab set Proxy Method to None and click “Apply system wide”.

Hope this will help!

share|improve this answer

Here's what I did:

According to this link:

Currently gwibber seems to expect a direct connection to the net, no use of a proxy. Gwibber should really query gnome for proxy information and use it for connecting to the net. You could also consider using libproxy.

So I went to

System Settings > Network > Network Proxy

and selected "None" in the "Method" box, instead of Automatic or Manual. Then applied it system wide and ta-da! Gwibber now works.

Hope I helped!

EDIT: Added a screenshot for reference image for reference

share|improve this answer

Have you set phone verification for your facebook? If yes please turn it off 1st. Login to Gwibber, and turn back your phone verification on facebook.

share|improve this answer
    
Yes, It's currently on. I switched it off now and tried again. But it's not working out. Gwibber is unable to even open the login page, then how can it communicate with my account? –  Ashish Jun 20 '12 at 15:22
    
Please Turn it OFF an login your Facebook from Gwibber. –  penreturns Jun 20 '12 at 15:23
    
Does this post help you @Ashish ? –  penreturns Jun 20 '12 at 15:35
    
Nopes :( No improvement. –  Ashish Jun 20 '12 at 15:42
    
Did you turn it off before login to Gwibber? If still cant login im sorry Sir. Because in my case, phone verification is the issue. But your's im not sure. –  penreturns Jun 20 '12 at 15:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.