Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i've been using ubuntu for ~2 months, when i installed it on my computer (laptop) it never overheat but a day, i don't know what happened, it over heated.. (70*C @ Idle) I've tryed what ever i found on the net, and as well, i can't change the CPU freq o.O, i5 M460 @ 2.53 GHz.. i have benn trying, jupiter (no result), lm-sensors (aswell), and the cpu freq thingy for unity (cpu wont move from 2.5GHz) Any help?

(i'm a C++ user and PHP coder...)

share|improve this question

closed as off-topic by Braiam, Eric Carvalho, Alvar, LiveWireBT, Avinash Raj Dec 24 '13 at 6:29

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Eric Carvalho, Alvar, LiveWireBT, Avinash Raj
If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers 4

Your computer's heatsink has probably got clogged. You can clean it by blowing through the heat vent of your computer. Or, you could dis-assemble your laptop and do a thorough cleaning of the heatsink. This procedure differs for different laptops.

Also make sure you have got the latest kernels and updates. Sometimes kernels have overheating/heat regression bugs.

share|improve this answer
    
about the heatsnik, i cleaned it many times without succses, and yup i got the last kernel (3.0 or something) and last updates, Ubuntu 11.10 ofcourse.. –  Moncef ben slimane Jun 20 '12 at 14:39
    
Ubuntu 11.10? Try upgrade to 12.04. –  upapilot Jun 20 '12 at 14:43

A few things to look at:

  • Check to make sure the air vents are not clogged on both sides (cool air inlet, hot air exhaust).
    • It's important to check that when you clean them you don't push the dust/hair back into the heatsink.
  • Are all the fans spinning up as expected when it gets warm?
    • If one fan is not working (i.e. slow or stopped), then the temp will probably rise. Todays laptops don't have "extra" cooling capability, so if it has multiple fans, both are probably necessary.
  • Can you boot from a bootable CD and use the system for a while to confirm it still gets warm?
    • It's possible an update to your system might have inadvertently disabled some part of the power settings.
  • If all else fails, you will probably have to disassemble the laptop to check the heatsink and fans.
    • I've worked on systems that pulled in hair and dust but it got stuck inside and was impossible to remove without opening it up.
share|improve this answer
    
thanks guys, it helps me, but why is my CPU freq blocked at max? –  Moncef ben slimane Jun 20 '12 at 15:04
    
You might have to change that from the BIOS settings. Lower your multiplier and that should reduce clock speed. –  upapilot Jun 20 '12 at 16:28
    
i'm on a Dell laptop, not a desktop, and when i had a fresh install of ubuntu, it worked, but nowadays, it wont.. –  Moncef ben slimane Jun 20 '12 at 18:11

There may be a problem related to your graphic card adapter as well. It's your computer using a HybridGraphics? Do you use the open source drivers? If YES, than as I said previously the overheating problem it's a graphic card bug. Try using this https://help.ubuntu.com/community/HybridGraphics and may fix your problem (had same problem with overheating and resolved it using that method).

share|improve this answer

I am 100% sure you're issue is the hybrid graphics and I have finally managed to tame this issue in most overheating laptops out there. Here is the ugly but workable hack:

yes there is an ugly hack, which needs to be in place so that it shuts down your discrete graphics card on boot and will disable it on ubuntu. Which I think should be fine as it will totally chill your system

Step1. goto terminal (alt+ctrl+t) and type:

sudo gedit /etc/rc.local

Step2. add the following lines before exit 0:

echo IGD > /sys/kernel/debug/vgaswitcheroo/switch

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

So your rc.local would look something like this:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo IGD > /sys/kernel/debug/vgaswitcheroo/switch

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

exit 0

Step3: Save and exit gedit, then type:

sudo reboot

Enter your password when required.

Basically what you did was, you switched to Integrated (IGD) graphics. then switched off the other one.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.