Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Wireless doesn't work on a Broadcom BCM4312

I have a problem connecting my Dell Vostro 1520 to wireless internet. Output of rfkill:

0: hci0: Bluetooth 
   Soft blocked: no 
   Hard blocked: no 
1: brcmwl-0: Wireless LAN 
   Soft blocked: no 
   Hard blocked: no 
2: dell-wifi: Wireless LAN 
   Soft blocked: yes 
   Hard blocked: yes 
3: dell-bluetooth: Bluetooth 
   Soft blocked: no 
   Hard blocked: no

I've tried other solutions like /etc/modprobe.d$ sudo gedit blacklist.conf and blacklisting the 43xx part, also tried getting sudo apt-get install firmware-b43-installer and sudo apt-get install b43-fwcutter and at last I've tried installing th privative(?) drivers for the Wireless Card. (Broadcom STA Wireless Driver), with following result for lspci:

0e:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01) 

It's obvious I've the switch turned [on], but it says that wireless is disabled by hardware switch and when I enter "System Settings -▸ Network -▸ Airplane Mode" it is turned [on] and when I turn it [off] and try to turn [on] the Wireless button, it goes to [off] position automatically.

Thanks for the help.

share|improve this question

marked as duplicate by fossfreedom Jun 20 '12 at 20:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please see - askubuntu.com/q/125529/35775 –  Web-E Jun 20 '12 at 15:02

1 Answer 1

You need to install either "b43-fwcutter/firmware-b43-installer" or "Broadcom STA proprietary restricted driver).

Try the first response in the link : How do I get a Broadcom BCM4313 wireless card working? Make sure Broadcom STA restricted driver is purged => "sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source".

I had the same issue, and in my case the Broadcom card is 4327, which is troublesome and works only with Broadcom restricted driver. The broadcom restricted driver is buggy , and freezes the screen. I wouldn't recommend this approach.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.