Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop Samsung RF411(Geforce 540M) is overheating when i run optirun glxspheres the temperature of the core jumps to 97C and the GPU to 72C and after some minuties the computer shutdown.

An strange thing is that the GPU in Windows goes 84C and the core stays in 86C. I think that should be a problem in controlling the fan speed.

I'm using Ubuntu 12.04, kernel 3.2.0-25-generic and the drive of nvidia is 302.17.

share|improve this question
    
This is amazing! Exactly my problem. I hope we find an answer some day. God damn you Optimus! –  Ziggy Mar 2 '13 at 3:59
add comment

2 Answers

As you said, the problem must be on the fan control. When I use optirun glxgspheres on my system it takes almost 100% of CPU, which is strange. Running with integrated card or with primusrun the cpu usage stays at ~25%. If you use Bumblebee frequently you can try to play with VGLTransport value in /etc/bumblebee/bumblebee.conf or using Primus.

But the problem should reside on all applications using a lot of CPU, and not in Bumblebee in special.

There are a lot of questions already posted here on how to control fan speed, so check them out and see if any solves your problem. Some examples:

Good luck.

share|improve this answer
add comment

Only installing the new beta version of Nvidia 319.12 with bumblebee that i could solve my problem.

sudo apt-get remove bumblebee-nvidia nvidia-current nvidia-settings

sudo apt-get install bumblebee-nvidia nvidia-319 nvidia-settings-319

Link http://orkultus.wordpress.com/2013/04/20/how-to-nvidia-319-12-drivers-in-ubuntu-based-systems-with-bumblebee/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.