Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am newbie of Ubuntu 12.04 with Gnome3 Shell.

  • Laptop Model: HP Pavilion DV6 1280US
  • Full Updates Installed.

I can hear sound played only when headphones are plugged in. Regular inbuilt speakers doesn't work.

Speakers are fine, it should be some technical configuration/driver issue with OS. They work in the Windows OS in the same laptop.

Kindly check these two snapshots:

Sound Settings - Output

Sound Settings - Input

Ubuntu Geeks Kindly help me!

share|improve this question
    
What model are the speakers? –  JXPheonix Jun 20 '12 at 13:43
add comment

5 Answers 5

Did you mess with Sound Settings below?

Settings

share|improve this answer
    
Yeah, this might also be the problem. –  JXPheonix Jun 20 '12 at 13:55
    
I am attaching the pics regarding the same sound issue, Kindly check this two (1) i50.tinypic.com/vcqnnt.png (2) i50.tinypic.com/21eu5ch.png –  linuxfreak12 Jun 20 '12 at 14:19
    
I think it's a device driver problem. You should check if your sound card is supported, or check your sound card vendor website and look for Linux system support. –  audrianore Jun 20 '12 at 14:46
add comment

A ubuntu geek is here!

The problem could be:

A) The cord from the speaker to the computer is frayed or otherwise damaged

B) You are plugging it in the wrong port (I have done this many times)

C) Speakers are utterly and entirely broken

D) A ubuntu problem!

Subsets of ubuntu problem:

-->A) A motherboard to headphone jack problem

-->B) A jack problem

-->C) A speaker problem

However, I highly doubt DA and DB because your headphones do work.

Could you please provide a speaker model, if possible? (If you don't find it, don't worry, I'm not sure what model my speakers are either.)

EDIT Alright, according to this picture: It looks like ubuntu sees the audio, but isn't sending signals to it correctly? Are you sure you don't

E) Don't have the volume turned up

But assuming, yes, its blasting at 100%, I'm going to comb the internet for answers. I'll write me an answer when done.

share|improve this answer
    
Speakers are fine , some technical configuration / driver issue with OS - Kindly check this two snapshots (1) i50.tinypic.com/vcqnnt.png (2) i50.tinypic.com/21eu5ch.png , Some driver or detection issue as they work in the Windows OS in the same laptop –  linuxfreak12 Jun 20 '12 at 14:23
    
@linuxfreak12 Alright, then i'm assuming the problem is not with the speakers or the cord. I am also assuming that the R710/730 are your speakers, which means ubuntu sees them. Is this also true? –  JXPheonix Jun 20 '12 at 14:28
add comment

I have a dv6-2119tx (Australian), which I got working with:

options snd-hda-intel enable_msi=1
share|improve this answer
add comment

I had this problem following a recent (post 12.04) update, and fixed it by adding the following two lines to /etc/modprobe.d/alsa-base.conf:

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

To make this change take effect:

sudo alsa force-reload
share|improve this answer
add comment

This seems to be a recent issue as I have this problem also in my HP Pavilion dv61355dx. The following is only a temporary fix to put sound on the in-built speakers but will not send audio to the headphones (at least in my case).

gksu gedit /etc/modprobe.d/alsa-base.conf

Make sure to back up the document before modifyng it and add the next line at the bottom of the document:

options snd-hda-intel model=dell-m4-3 enable_msi=1

I know that the model says it's a Dell, but now I can hear sounds on my laptop regardless of the absence of audio though headphones. I tried this options configuration but nothing changed:

options snd-hda-intel model=hp-dv5 enable_msi=1

I hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.