Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to Ubuntu 12.04, windows pop up with white color on white text. I am lost, confused, feeling very stupid and am not sure what to do next. I would greatly appreciate it if someone could please take a look at my issue.

My problem is similar to this person's experience:

Hope-DT GTK+ theme displays white fonts after upgrade to 12.04

I see on advanced settings I am using the 'Ambiance Blue' GTK+ theme, whatever a GTK+ is. Changing this to any of the other GTK+ themes fixes the white on white problem, but makes the background colours of minimised windows really ugly - i.e. like graphics of early 1980s PCs. Only 'Ambiance Blue' seems to set them right.

Looking at White text on white background problem, it seems I need to manually edit some configuration files. There's 3 configuration files and I didn't know which one to use, so I changed them all. Now I have:


**/usr/share/themes/Ambiance Blue/gtk-3.0/gtk.css:**

/* default color scheme */
@define-color bg_color #cdc3b8;  
@define-color fg_color #262626;  
@define-color base_color #accdff;  
@define-color text_color #262626;  
@define-color selected_bg_color #01b9fc;  
@define-color selected_fg_color #ffffff;  
@define-color tooltip_bg_color #A3D0FF;  
@define-color tooltip_fg_color #023C79;

**/usr/share/themes/Ambiance Blue/gtk-3.0/settings.ini:**

    [Settings]
gtk-color-scheme = "base_color:#accdff\nbg_color:#cdc3b8\ntooltip_bg_color:#a3d0ff\nselected_bg_color:#ffffff\ntext_color:#262626\nfg_color:#262626\ntooltip_fg_color:#023c79\nselected_fg_color:#ffffff\nlink_color:#1448dd\nbg_color_dark:#373b3c\nfg_color_dark:#d2dbdf"

**/usr/share/themes/Ambiance Blue/gtk-2.0/gtkrc:**


gtk-color-scheme = "base_color:#accdff\nfg_color:#262626\ntooltip_fg_color:#023c79\nselected_bg_color:#01b9fc\nselected_fg_color:#ffffff\ntext_color:#262626\nbg_color:#cdc3b8\ntooltip_bg_color:#a3d0ff\nlink_color:#1448dd"

I restart the computer and then go into advanced settings and select 'Ambiance Blue' and I still get white on white.

Q1. Which of the 3 configuration files actually matters?

I am not using unity; I'm not sure what I'm using. Gnome 2 or gnome 3 or gnome-something or something like that I think. Here are some environment variables:

GTK_MODULES=canberra-gtk-module:canberra-gtk-module
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
DEFAULTS_PATH=/usr/share/gconf/gnome-classic.default.path
XDG_CONFIG_DIRS=/etc/xdg/xdg-gnome-classic:/etc/xdg
DESKTOP_SESSION=gnome-classic
MANDATORY_PATH=/usr/share/gconf/gnome-classic.mandatory.path
GDMSESSION=gnome-classic
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
XDG_DATA_DIRS=/usr/share/gnome-classic:/usr/share/gnome:/usr/local/share/:/usr/share/
XDG_CURRENT_DESKTOP=GNOME

Q2. Is there some way of testing this without restarting the computer each time? (I tried turning all numbers in one of the files to #000000 but it didn't seem to do anything.

Q3. Exactly which number do I need to change to get rid of the white-on-white?

share|improve this question
    
This might not help but you could try a alternative theme I got a Radiance blue theme from gnome-look.org gtk3 section its a nice theme and works well sorry if this is not quite what your looking for but it is at least a suggestion... –  mark kirby Jul 14 '12 at 12:06
    
Have you tried simply logging out and logging in again...I'm sorry, I haven't read the full question yet, but I know there is a severe bug that occurs when switching certain themes, that causes the coloring to screw up. –  TenorB Jul 26 '12 at 5:29

2 Answers 2

These are the ones that need to be edited:

/usr/share/{theme}/gtk-2.0/gtkrc 

or

~/.themes/{theme}/gtk-2.0/gtkrc

change it to:

text_color:#000000
bg_color:#ffffff

is the code for black text and white boxes I am using Equinox Evolution Midnight on Sabayon linux with openbox and lxappearance does not change the colour of the white text on black text boxes or white text on white background in firefox (also libreoffice had reversed colours, yuck)

I hope someone spends less time figuring this out because of this answer.

share|improve this answer

If you have not tried settings under "Appearance" (available from the dash), please try the available settings. There are two tabs: Look and Behaviour. Try the default settings (because capacity, type and size of the monitor may affect the "Look").

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.