Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Ubuntu refuses to output audio via HDMI

In ubuntu 11.10, in system settings -> sound, under the output tab, there was a menu to select the audio output device, so I could connect my laptop to my TV and select if I wanted to use the laptops speakers or use the HDMI, and the TV's speakers.

I am now using ubuntu 12.04, I just connected the hdmi cable to my laptop and TV, and all I see in settings -> sound is this:

enter image description here

Any idea how to select to use TV's speakers?

share|improve this question

marked as duplicate by Eliah Kagan, fabricator4, hhlp, Jorge Castro, Tom Brossman Dec 25 '12 at 21:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Are you using an nvidia video card to do the hdmi out? –  darryn.ten Jun 20 '12 at 12:50
    
How can I find out? –  AnPel Jun 22 '12 at 19:40

2 Answers 2

I'm sure it is a little late, but I thought I'd post a comment to help those browsing. I am running the NVidia driver, and when I plug in HDMI I first have to make sure the secondary display is enabled, thus activating the entire HDMI setup (including audio). Once the video is enabled and working, the sound settings includes the additional HDMI/DisplayPort audio output option.

Good luck!

share|improve this answer

You can try installing program "PulseAudio Volume Control" (sudo apt-get install pavucontrol) and in tab "Configuration" select profile mentioning HDMI.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.