Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to edit a file in 12.04 desktop. Previously (in Lucid) I could right click, select 'open with', and type in 'gksudo gedit' - which was then added to the list of available 'open with' programs. This functionality has completely disappeared in 12.04 - or am I missing something?

I know I can fire up a terminal and type it in there - but this is supposed to be user friendly, not going back to the bad old days. I may as well use 'sudo nano'!

Regards John

share|improve this question
    
gksudo may be missing from the install? –  darryn.ten Jun 20 '12 at 12:52

2 Answers 2

Add the trick to your nautilus shortcuts:

wget http://www.liberiangeek.net/blog/tools/libnautilus-gksu.so
sudo cp libnautilus-gksu.so /usr/lib/nautilus/extensions-3.0/

Upon next restart, you should fidn "Open as Administrator" in all your right click menus.

share|improve this answer

If you right click a file on the desktop, the Context Menu in Ubuntu 12.04 contains an option where it reads Open with other application..., selecting it, you have the: use a custom command that enables you to perform what you're used to do.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.