Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just upgraded to the LTS and now I can't watch any videos on Your Tube via Flash in either Firefox or Chrome.

I had the issue with Chrome before I upgraded, but I could still see them in Firefox without an issue and I figured the upgrade would fix this.

I am getting the error message 'The Adobe Flash plug-in has crashed' and then underneath the viewing panel it says 'Upgrade to Flash Player 10 for improved playback performance. Upgrade Now or More Info.'

I have checked in the software centre and it is showing a green tick next to Adobe Flash plug-in for Mozilla.

Can anyone help me please? I really need to be able to view videos.

Thanks loads,

Kat x

share|improve this question

closed as off-topic by bain, Eric Carvalho, Sneetsher, Lekensteyn, bodhi.zazen Jun 30 '14 at 19:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

Have you upgraded from 9.10 or 8.04 LTS? – Stefano Palazzo Nov 29 '10 at 10:45

I have checked in the software centre and it is showing a green tick next to Adobe Flash plug-in for Mozilla.

It would be better if you could try manually installing the Flash plug-in form the adobe site.


share|improve this answer

when you upgraded to 10.04 it may have disabled restricted extras open software center type in ubuntu restricted extras.

share|improve this answer

You could try using Flash-aid:

You should still read a bit more about it, for example, here:

I had some problems with Flash at first, and this solved them. Then I had some minor transitional issues after the fix, but some Firefox updates solved them and now it works perfectly (I use Ubuntu 10.10, however).

share|improve this answer
I'm not sure, it had an orange background with something that looked like someone's arm. I think it was 9.10. – Kat Nov 29 '10 at 11:14

Its not clear if your running 32-bit or 64-bit. However i have the same problem that re-occurs everytime an update comes in that upgrades the flash-plugin package. For 64-bit initially check your /usr/lib/nspluginwrapper/i386/linux/npviewer setting is as in this post

Then using the synaptic package manager (under system --> administration menu) search for "flash" and re-install the "flashplugin-installer". It works for me everytime, hopefully this will assist you.

share|improve this answer