Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using 12.04 LTS dual boot, and I can't use the bluetooth service in Ubuntu. It works fine with Windows 7. In Ubuntu I can turn on the bluetooth from the titlebar but when I switch on the visibility it automatically switches back (I'm using GNOME 3 environment).

All this happened after the 1st update (worked fine before then).

share|improve this question
    
I hve the same issue, recently upgraded and my bluetooth dongle won't turn on. Seems like this bug bugs.launchpad.net/ubuntu/+source/linux/+bug/985689 –  sergio91pt Jun 22 '12 at 11:08
    
I found out the solution from ubuntuforumns, and it really worked for me..uninstalling and reinstalling 'bluez' solved my problem. Hope this will help you too..ubuntuforums.org/showthread.php?t=1812493 –  hari_lionheart Jun 22 '12 at 18:11

6 Answers 6

Found an easier solution than reseting BIOS!

sudo hciconfig hci0 reset

bluetooth was enabled on ubuntu 12.04.

I could do file transfer between Nexus7 and my laptop. but nexus7 stopped playing music and laptop started playing music!

share|improve this answer
1  
Doesnt help...! –  AsheeshR Aug 12 '13 at 14:46
1  
You might need to unblock the device first: Check sudo rfkill list to see if it's blocked, then unblock it: sudo rfkill unblock <id>. Now if you do sudo rfkill list again you will see the new device named hci0. You can now reset it using the above command. I needed to restart afterwards to make it work again. –  jmiserez Nov 3 '13 at 23:47
    
I had trouble when I tried a dedicated bluetooth (Sennheiser BTD 500) audio dongle instead of my regular one and must have messed something up on my desktop. I couldn't pair my Wacom and headset again, even after reboot and rfkill. This one worked! –  LiveWireBT Jan 23 at 15:42
    
Tried but: Can't get device info: No such device –  Natim Mar 21 at 16:15
    
sudo rfkill unblock 0 did the trick thanks :) –  Natim Mar 21 at 16:15

I've got the same issue, and it turned out that Bluetooth was turned off in windows... If you use both windows and ubuntu on the same machine, try this command:

rfkill list all

If it says that Bluetooth is soft blocked then try to enable it on windows and then check again if it works on ubuntu also.

share|improve this answer
1  
sudo rfkill unblock <id> to unblock the device. –  jmiserez Nov 3 '13 at 23:45
1  
I don't see any bluetooth in the list: 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no –  Rasoul Jan 14 at 18:05
    
@Rasoul the same for me; did you managed to make it work? if so, how? please –  Jo Rijo Apr 15 at 19:42

I got this problem since I installed 12.04. I have tried many ways to install bluetooth, then changing if my bluetooth is soft blocked or not, then reinstall my bluetooth software on Ubuntu I had done it all.

But I found the BEST WAY to enable bluetooth with:

  1. Restart your Ubuntu

  2. Go to BIOS program (through Del or F2 - its optional based on your computer)

  3. Set the BIOS to 'reset to factory setting' usually using F9 or else its based on your type of BIOS

  4. Startup, then go to your bluetooth you will found that your bluetooth wont disabled again.

Good luck.

share|improve this answer

Just had this problem (on 12.10), solution I found: kill blueman-applet and start it again. Run blueman-applet & from a terminal to start it.

share|improve this answer

Check your bluetooth device ,see if the bluetooth is switched off by hardware switch. If that is the case, turn the bluetooth hardware switch on.

share|improve this answer

Setting to Factory Defaults helped me instantly with the Wireless and Bluetooth. They were shutdown in Ubuntu 13.04 for me.

share|improve this answer
    
Welcome to Ask Ubuntu! Setting what to factory defaults exactly? You posted this as an answer to the original question, but perhaps you meant to comment to an other answer? –  gertvdijk Jun 23 '13 at 10:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.