Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

When I start Skype, the Startup sound sounds like that my speakers is going to break any time (kind of like nails scratching a blackboard).

But when I go to /usr/share/skype/sounds to find the startup sound, I opened it and the file doesn't sound anything wrong.

How do I fix this? It sounds bad no matter how I start it.

share|improve this question

marked as duplicate by mikewhatever, karel, Eric Carvalho, Warren Hill, Alvar Oct 2 '13 at 10:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
My skype startup sound is oftentimes like that, and I suspected it was because it runs at startup when a lot of other things are running and initializing, so perhaps it gets interrupted by higher-priority processes. Does yours sound OK if you quit and restart when the system is idle? –  Marty Fried Jun 20 '12 at 1:31
    
@MartyFried After I restarted my computer I started Skype, and the Startup sound still sounds bad. I only have the GNOME login sound in Startup Applications. –  Emerson Hsieh Jun 22 '12 at 3:27
    
Did you start skype right away after restarting? On my system, it seems like a lot of CPU gets used for several minutes - I think it may be by gwibber updating messages, etc. I don't use it, so I recently deleted gwibber, and so far, Skype sounds much better on startup. But it always sounded OK if I quit Skype, and then reran it when nothing else was happening on the computer. –  Marty Fried Jun 22 '12 at 19:06
    
@MartyFried Skype sounds bad no matter how I started it. –  Emerson Hsieh Jun 28 '12 at 2:13

8 Answers 8

up vote 4 down vote accepted

The best solution to this problem is to disable the Glitch Free Audio part of Pulse, covered elsewhere

Skype and VLC sounds sizzle/distorted/bad

share|improve this answer
    
worked for me...thanks –  HDave May 13 '13 at 19:22

Go to Startup Applications Preferences and edit the startup line for Skype:

sh -c "sleep 10 && skype"

Play with the 10 value. Get it lower until you start hearing the scratch. If you hear the scratch, raise the value by 1 again.

share|improve this answer
    
But he says that it sounds bad no matter when he starts it, so what is the point of delaying the startup? If you were reading the comments, you would have seen that this is what I was trying to determine. –  Marty Fried Jun 28 '12 at 5:47
    
@MartyFried Sorry, but I fail to see where he states that starting Skype, with a certain delay, still makes the sound scratchy. –  David M. Sousa Jun 28 '12 at 13:43
    
Well, that's true, but he does say he restarts it manually, which is a lot more than 10 seconds later. I was trying to ascertain that he did restart it later, and he seems to confirm that this is what he did. But it seems that somebody must have found your post helpful, so don't worry about it. I use a similar version of that command for several of my other apps that need a delay; I use this variation: bash -c "sleep 10;/usr/bin/skype". –  Marty Fried Jun 28 '12 at 17:36
    
I also had the GNOME login sound, and it sounds REALLY awful when you combine the Scratchy Skype sound and the Login Sound together. –  Emerson Hsieh Jun 29 '12 at 1:05
    
@DavidM.Sousa Do I have to type that line in the terminal to delay the start? –  Emerson Hsieh Jun 29 '12 at 1:07

This boils down to one of two reasons (or a combination):

  1. CPU loaded at login when sound is played
  2. Some intrinsic problem with the Skype WAV files

Solution to (1) is to delay start OR temporarily elevate Skype priority

You can either delay the startup, as David Sousa/Marty Fried's answers indicate, OR you can temporarily elevate Skype's priority at startup to reduce any CPU contention issue.

This solution uses nice/renice, and requires adding the specific command with visudo (because only root can start processes with elevated priority). I'll expand on this later since the OP (Emerson) indicates this is not his problem -- Skype login sounds grainy even when he starts Skype after his computer has been idle for a few minutes.

Solution to (2) -- try changing the sound into a more standard format (resample)

  • Open a terminal, go to /usr/share/skype/sounds
  • Backup all files (they're tiny) with sudo tar -cvf originals.tar *.wav
  • Rename: sudo mv SkypeLogin.wav SkypeLoginOld.wav
  • Install SOundeXchange with sudo apt-get install sox (small CLI utility)
  • Resample the login sound to a standard 48000 Hz stereo format:
    sudo sox SkypeLoginOld.wav -c 2 -r 48000 SkypeLogin.wav
  • Now start Skype -- is it better?

If not, please try playing the Skype directory sounds in a regular player, and see if they still sound bad.

share|improve this answer
    
Still sounds bad... But when I play them in a Regular player they sound nothing wrong –  Emerson Hsieh Jun 30 '12 at 0:45
    
Can someone else confirm (that it sounds bad no matter what)? Then it's bug and I strongly recommend filing it as such. –  izx Jun 30 '12 at 1:03

Found the solution. Kind of.

I went to /usr/share/skype/sounds, then I copied SkypeLogin.wav to my Music Folder in my home directory.

Then I went to Skype Options and Clicked on the Notification Settings.

Next I changed the Startup Sound file from the one in /usr/share/skype/sounds to the one in my Music Directory.

Last I logged out and logged in and Skype Sounded much better!

Maybe Skype can't read /usr/share/skype/sounds, not sure what caused the problem but all works great now.

share|improve this answer
1  
Well, you can either read a file or not at all. It isnt like a vinyl record :p –  izx Jun 30 '12 at 6:09
    
@izx I think that this problem can be caused because skype isn't run with root access. Or that folder is opened by Skype with read permissions? –  Lucio Dec 5 '12 at 17:58

Just uninstall skype and re-install it from terminal using these commands

Install Skype on Ubuntu 32 bit

wget -O skype http://download.skype.com/linux/skype-ubuntu_4.0.0.8-1_i386.deb
sudo apt-get install libxss1
sudo dpkg -i skype && sudo apt-get -f install && sudo rm skype

Install Skype on Ubuntu 64 bit

wget -O skype http://download.skype.com/linux/skype-ubuntu_4.0.0.8-1_amd64.deb
sudo apt-get install libxss1 lib32stdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1
sudo apt-get -f install
sudo dpkg -i skype && sudo rm skype
share|improve this answer

I have found that these scratchy sounds are the result of a USB headset combined with a regular sound board (integrated or not).

What I did to solve this was to install Pulse Audio Preferences (from the Software center). Once installed, open it and enable "simultaneous output". Then open the sound settings, and highlight the "Simultaneous output on built in ...". You shouldn't have to reboot, but you may have to.

share|improve this answer

Sometimes scratchy Noises are due to a program called Skype Wrapper. Its an independent program for adding a bar (Like the ones used for when Rythmbox changes songs) I would check to see if you have it by using:

sudo dpkg-query -Wf '${Installed-Size}\t${Package}\n' | sort -n

Then after remove it by using:

Sudo apt-get remove skype-wrapper

Restart skype, It's not 100% but it helped me.

share|improve this answer

Modified the permissions of the wav files:

chmod 777 /usr/share/skype/sounds/*

This will make the Skype sounds much better.

share|improve this answer
2  
Never suggest to blindly chmod 777 anything! –  guntbert Oct 1 '13 at 18:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.