Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After an update with update-manager in 12.04, MPlayer is not working anymore. It needs ffmpeg, but it can't be installed due to unmet dependencies. I added a PPA for ffmpeg, but did not solve the problem.

See output:

Python (v2.7) requires to install .... GStreamer ffmpeg video plugin. 
Codecs to play mpeg, divx, mpeg4, ac3, wmv and asf files.

Using install, I get an error messages that it can't be installed due to unmet dependencies. See list below:

The following packages have unmet dependencies:

gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 6:0.10.4.0ubuntu0jon2.2 is to be installed
                      Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                      Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed
                      Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1 is to be installed
                      Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                      Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                      Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed

How can I fix this problem?

share|improve this question

2 Answers 2

I had the same problem and I found the solution on web.

It is due to the installed PPA:

Try to run the following:

sudo add-apt-repository ppa:jon-severinsson/ffmpeg
sudo ppa-purge ppa:jon-severinsson/ffmpeg

Then run totem and install the missing plugin

share|improve this answer

I noticed that request contains gstremer plugins can be divided on i386 and x64 plugins. If you deselect x64 if you have x86 linux or deselect i386 for x64 linux it would install with no conflicts.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.