Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem connecting my Dell Vostro 1520 to the Internet by Wireless. The output of rfkill list is

0: hci0: Bluetooth Soft blocked: no Hard blocked: no 1: brcmwl-0: Wireless LAN Soft blocked: no Hard blocked: no 2: dell-wifi: Wireless LAN Soft blocked: yes Hard blocked: yes 3: dell-bluetooth: Bluetooth Soft blocked: no Hard blocked: no

I've tried other solutions like /etc/modprobe.d$ sudo gedit blacklist.conf and blcklisting the 43xx part, also tried getting sudo apt-get install firmware-b43-installer and sudo apt-get install b43-fwcutter and at last I've tried installing th privative(?) drivers for the Wireless Card. (Broadcom STA Wireless Driver). The result of lspciis 0e:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01). Thanks. EDIT: it's obvious I've the switch turned on, but it says that wireless is disabled by harware switch.

share|improve this question
add comment

1 Answer

Is this solved or not? Not sure with you recent edit.

If not I would remove any of the broadcom packages you have installed and start again from fresh. So fire up a terminal

sudo apt-get purge firmware-b43-installer b43-fwcutter

then I would install the other broadcom package which always works for me

sudo apt-get install  bcmwl-kernel-source

or if you prefer the other package

 sudo apt-get install  firmware-b43-installer b43-fwcutter

That has always worked for me in the past with Broadcom wifi

You can check if your wifi card is blacklisted if not by typing

cat /etc/modprobe.d/* | grep bcm

Anyway give it a go and let us know how you get on

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.