Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Fedora and Ubuntu 12.04. Both have different Swap Partition. Fedora using its own Swap space. But Ubuntu using both two swap partitions. I want to stop that. I want Ubuntu 12 to use its own Swap Partition.

  • sda9 - Ubuntu (/)

  • sda11 - Swap (4.9 GB)

  • sda10 - Fedora (/)

  • sda12 - Swap (4.9 GB)

All are logical partitions.

share|improve this question
    
Anyone, please explain how I can or where I can add the "noauto" command in the "fstab" file? –  Curious Apprentice Jun 21 '12 at 2:25
add comment

3 Answers

I suggest that you get rid of the extra swap line in /etc/fstab.

share|improve this answer
add comment

Please add the noauto option in /etc/fstab for your Ubuntu system's sda10 partition.

share|improve this answer
add comment

The swap space is set in /etc/fstab. In your case you probably want Ubuntu to use sda11 partition, so you should remove the line in fstab that contains the /dev/sda12 partition.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.