Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried a lot of proposed solutions, most of them adding files to /etc/pm/config.d, as well as WiFi stops working after waking from suspend with a Broadcom 43225 and nothing has worked.

hardware info:

[colleen@colleen-HP ~]$ sudo lshw -C network
[sudo] password for colleen: 
  *-network               
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: eth0
       version: 06
       serial: 2c:27:d7:b1:ea:67
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=N/A latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:41 ioport:4000(size=256) memory:c1404000-c1404fff memory:c1400000-c1403fff
  *-network
       description: Wireless interface
       product: Centrino Wireless-N 1000
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0d:00.0
       logical name: wlan0
       version: 00
       serial: 8c:a9:82:99:48:8c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-21-generic-pae firmware=39.31.5.1 build 35138 ip=192.168.0.4 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:48 memory:c5500000-c5501fff

Is anyone else still having this problem? The two solutions I haven't tried are installing wicd and upgrading because I've heard both are kind of unstable/buggy and wicd frankly scares me.

pastebin of dmesg: http://pastebin.com/uJQYgzEM

share|improve this question
    
Colleen, can you (1) boot from "off" (2) sleep (3) wake (4) Pastebin the output of dmesg (instructions) (5) write down the URL you get from step 4 somewhere (6) shutdown (7) boot, and since you'll have internet access then, post the URL as a comment (or edit your answer?) Many thanks! –  izx Jun 21 '12 at 19:43
    
how about both? pastebin.com/uJQYgzEM –  Colleen Jun 21 '12 at 22:49

3 Answers 3

up vote 1 down vote accepted
+50

Note: iwlagn was renamed to iwlwifi in Ubuntu 12.04 and later, so replace appropriately in the below steps if you are on 12.04.

This line, immediately after the PHY(sical) wifi interface is brought up, tells us about the source of your problem:

[29054.603501] iwlagn 0000:0d:00.0: fail to flush all tx fifo queues
  • It is related to this bug, even though you have a 1000 and not a 6250.

Solution:

  • After boot:
    1. sudo modprobe -r iwlagn
    2. sudo modprobe iwlagn bt_coex_active=0
    3. Suspend/wake -- does it work now?

If it does, make it permanent by adding a file /etc/modprobe.d/iwl.conf, containing only this line:

options iwlagn bt_coex_active=0
share|improve this answer
    
:D :D :D It worked!!! THANK YOU!!! –  Colleen Jun 26 '12 at 16:10
    
sidenote: added this as an alias to my bashrc by doing: alias reboot_wireless='sudo modprobe -r iwlagn; sudo modprobe iwlagn bt_coex_active=0"' but when I open a new terminal window and say reboot_wireless it just says > like it's waiting for me to finish a command. What am I doing wrong? –  Colleen Jun 26 '12 at 16:17
    
nvm -- had an extra " –  Colleen Jun 26 '12 at 16:27
    
@Colleen, added a line at the end on how to make the setting persistent :) Very glad it worked for you. –  izx Jun 27 '12 at 10:53

First thing I would try is switching the wi-fi device off and back on again using the switch / button on your laptop or card (or remove the dongle and plug it back in).

share|improve this answer
    
I've tried that too. The switch, I mean-- it's an internal card. –  Colleen Jun 19 '12 at 15:24

it's a known issue which can be solved easily.

Check with

Code:

lsmod | grep -iE '802|ndiswr|forced|8139|hci|usb|1394|hid|..tv'

which modules can cause problems (left column) and add your wireless driver (here ath5k) to this list. Create a file with:

Code:

sudo touch /etc/pm/config.d/00sleep_module sudo chmod +x /etc/pm/config.d/00sleep_module gksudo gedit /etc/pm/config.d/00sleep_module

and add these modules according to this example:

Code:

SUSPEND_MODULES="$SUSPEND_MODULES ehci-hcd uhci-hcd usbcore forcedeth" save, close, and check SUSPEND/HIBERNATE

Edit: This unloads the modules and reloads them, so wake-on-wireless will not work (anymore)

share|improve this answer
    
I'm confused by "so wake-on-wireless will not work (anymore)"-- what do you mean by "wake-on-wireless" –  Colleen Jun 23 '12 at 22:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.