Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to connect with ipv6 enabled networks with my Broadcom Wireless card under Ubuntu 12.04. The wireless card model is BCM4306.

$lspci
$Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
$Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

I have been unsuccesful to connect through an ipv6 address, but I can still connect to a network when assigned an ipv4 address. While searching for an answer or a solution, I know the kernel can handle dealing with ipv6. So, what's left to question should be the hardware handling the connection. Unfortunately nothing comes up when I specifically try to search for information on BCM4306 ipv6 capabilities.

I just tried using a wired connection to establish an ipv6 only connection to the network I'm on right now, but I got the same behavior of constant disconnections. Maybe it's not the hardware? I don't know..

I don't want to disable ipv6 on my machine as relevant networks I'll be connecting to will be using it exclusively, but I'm not sure what is wrong and which parts should I replace/fix to get this working.. Could someone please point me in a fruitful direction to get ipv6 working under Ubuntu 12.04?

share|improve this question

2 Answers 2

Network card drivers have nothing to do with IPv6 support. IP is layer 3 in networking (DoD/OSI model) and your card with its drivers only take care of layer 2.

If we will have IPv7 some time later or go back to IPX, you don't have to worry about NIC drivers - they're not working on this level, it's your OS (kernel).

enter image description here

In the image above, the "Process Application" is just the responsibility of the application, "Host-to-Host" is the transport layer, provided by the kernel, "Internet" is about addressing and is also done by the kernel. "Network Access" is what the NIC drivers and hardware are about.

While some of the operations in the pieces in the layers above (especially TCP) can be offloaded on the hardware, it's not a big deal if it can't, as it's just done in software then.

In case you have general IPv6 connection issues, you'll have to be more specific about what you're trying to accomplish and what you've tried.

share|improve this answer

If you are using the broadcom-sta drivers then I believe they are not IPv6 compatible. At least not for the advertisement. I have the same problem with my card using the broadcom-sta drivers. My card (BCM43227) is not supported by any other driver, but it seems yours is.

Looks like you can try the b43legacy drivers and possibly the b43. My old laptop used the b43 with IPv6 just fine but you would have to test out b43legacy to see if it will support IPv6.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.