Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Feeling disempowered by Ubuntu's new bug reporting policy/system. My Intel i5 machines have all experienced daily (if not more frequent) freezes, but it's very difficult to report bugs now and policy instead is just for ubuntu to collect counts; no way for me to see that anything is (or is not) being worked on.

I've just experienced a freeze and now on reboot I'm stuck in a cycle of "Ubuntu has an internal error" (presumably Ubuntu never experiences an external error...) do you want to report it? Yes. Oh another internal error...

Apport crash screen

It looks like this report could contain useful information. Is there anyway to make sure it gets provided to the people who can fix it?

share|improve this question
1  
Experiencing the same error! Switching between real (less frequent) and non-noticable hangs (frequently). It startet after the latest kernel update, three days ago! Any guess when this bug will be fixed. I am refusing to disable the handler because: How do I know that the bug has been fixed?!? –  user143523 Mar 26 '13 at 15:12
add comment

2 Answers 2

up vote 5 down vote accepted

Install xdiagnose version 2.5.1, which I uploaded to precise-proposed the other day.

The problem is that the Intel graphics driver has these weird "false gpu hangs". The GPU locks up but then recovers so that you don't actually notice anything, but it still is enough to trigger the error handler. Disabling apport doesn't disable this handler; 2.5.1 disables the handler directly.

share|improve this answer
    
I'll look into xdiagnose, thank you. Of course, the more serious issue is less the false hangs and more the real ones! LOL, software centre crashed while trying to enable proposed. –  artfulrobot Jun 20 '12 at 12:58
    
True, this may result in making it more difficult for people with real hangs to report them, but at least it'll stop the popups for people who aren't having hangs. –  Bryce Jun 20 '12 at 18:46
    
Sounds like my question is answered, albeit not in the way I'd imagined: The devs don't need the stuff because this particular problem has been identified and fixed upstream. –  artfulrobot Jun 22 '12 at 10:17
    
Wow, my computer (Dell Inspiron 14Z ultrabook) has been freezing every few days ever since I bought it ... I turned off "Enable automatic crash bug reporting" in xdiagnose last week and it hasn't crashed since. Thanks!! –  Steve B Jan 31 '13 at 13:22
    
is there any way around this without disabling the apport? I mean I want to report other bugs! –  Keivan Mar 28 '13 at 20:41
show 3 more comments

You may want to disable Apport:

sudo gksu gedit /etc/default/apport

change "enabled" from "1" to "0", then save the file.

You can always re-enable it later on if you want, by changing "enabled" from "0" back to "1", or you can enable Apport temporarily, using the following command:

sudo service apport start force_start=1
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.