Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having real issues reinstalling 10.04 to an SSD - I had one SSD fail, and have replaced it with a brand new one, but the 10.04 installer fails at beginning to write files to the disk with this error:

[Errno 30] Read-only file system: '/target/bin'. 


  • Windows XP will install to this SSD with no issues
  • I can install 10.04 to a standard hard drive with no errors.

What is happening that is stopping me from installing 10.04 to this drive? I am positive that there is no issue with the SSD (I have two brand new, identical SSDs which both encounter this error.) They are OCZ Vertex II 60gb drives.

I have tried partitioning the drive using gparted on another machine, leaving 5mb free at the start of the drive, and having a single partition for /, and a 1gb swap partition. "Round to cylinders" was unchecked. The partitioning was successful, and the drives can be mounted on my other machine, but the 10.04 installer encounters the same error.

Any suggestions for what to try next would be appreciated, or I'll be stuck with reverting to a HDD!

share|improve this question
up vote 2 down vote accepted

Figured it out - the old SSD (that died) was of an earlier generation and used ATA mode. The newer drive didn't like this - I set the BIOS to AHCI mode and it worked okay.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.