Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have dell E6520 laptop with latest ubuntu 12.04. I also have the EC (ExpressCard) with the USB3.0 ports. The card is recognized by ubuntu (I can see in in lspci), but when I plug in the external USB3.0 HDD into the slot nothing happens - hot-plugging the drive does not work.

The same drive works as hot-plug into the USB2.0 port (built-in); it also works as USB3.0 if I plug it in before boot and boot with it plugged in.

How can I sort out this hot-plugging issue with USB3.0 ?

NOTE: when firstly installing ubuntu 12.04 the hot-plugging the same USB3.0 into the same EC car did work! It stopped working after upgrade to a new kernel.

share|improve this question
add comment

1 Answer 1

My usb3 drive was working until I did the update too. I fixed it by adding the line

blacklist uas

to the file /etc/modprobe.d/blacklist.conf.

Hint found on:

This worked for me, once I rebooted and reattached the USB drive to my computer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.