Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm facing a problem with all the kernels installed at my system (Ubuntu 10.10 64-bit).

Installed kernel versions: 2.6.32-21 up to 2.6.35.23.

The booting halted with the following error:

init: .: line 61: can't open '/scripts/functions'
Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: init not tainted

Only the first one (2.6.32-21) was working up until know.

I asked for help at ubuntuforums.org and i was told to check if there's any problem regarding my graphics card (ATI Radeon).

I uninstalled all the ATI-related packages as well as all the unecessary xserver-xorg-video-* drivers that were installed.

I then rebooted and from then on ALL of the kernels halt with the same error (i.e. it didn't fix the problematic kernels, it just broke the only one that was working...)

Any ideas on what i should try next?

Thanks in advance.

Pavlos.

share|improve this question

4 Answers 4

up vote 2 down vote accepted

Problem Solved!
To anyone interested, here's my solution:
It was update-initramsfs which caused the above errors (invalid predicate -regextype' find: invalid predicate -regextype').
The created initrd images were broken.
Something was wrong with findutils, so I just reinstalled the package (as well as initramfs-tools) and the problem's gone :-)
Thanks once again for helping out.

share|improve this answer
    
Had this problem on a server. I also needed to change the attributes on find to be able to reinstall findutils: chattr -i /usr/bin/find and chattr -a /usr/bin/find. –  mniess Jul 9 at 14:05

Try booting into recovery mode. If that works, run sudo update-initramfs, reboot. See if you can boot into the normal mode.

If recovery mode is not working, I think the only viable way would be to reinstall (back up all your files from /home somewhere, reinstall, copy them back - use a LiveCD for that).

share|improve this answer
    
Thank you both for answering. @Salih: I guess that if there was a problem with RAM, then i wouldn't be able to boot with any kernel from the start. Isn't that right? @evgeny: Recovery mode is also not working. I'm currently stuck at chrooting and trying to reinstall multiple kernel versions, but still nothings seems to work.. –  Pavlos G. Nov 29 '10 at 1:59
    
Update: i forgot to tell you that update-initramfs is always giving me the following warnings (for every kernel): find: invalid predicate -regextype' find: invalid predicate -regextype' find: warning: unrecognized format directive `%Y' –  Pavlos G. Nov 29 '10 at 3:32
    
I daresay your system broke. Like, entirely. A clean reinstall might save you time than trying to fix everything. –  evgeny Nov 29 '10 at 3:47
    
I daresay i have to agree with you :-) But as a technician, i'm always interested to know what the exact problem is, and that's not gonna happen if i just reinstall. Anyways, thanks for the feedback, i'll give it another shot tomorrow and if nothing happens, i guess i'll go on with the reinstallation... –  Pavlos G. Nov 29 '10 at 3:55

I had, ones in a life time Kernel Panic... and it was scary :) The problem was related to a hardware failure. In my occasion, it was a newly purchased RAM module. The first time I installed the module, system was booting normally, but suddenly it started to give me kernel panic. What I did, was to check my RAM.

In the GRUB menu there is a an entry for Memtest-86+. Try it, to see if something is wrong with your RAM. Be patient though, it may take some time to give some results...

UPDATE You can use Live CD and then from the menu choose Test memory

alt text

share|improve this answer
    
I'll let Memtest scan for possible defects as you said and i'll let you know if it finds anything. –  Pavlos G. Nov 29 '10 at 3:32
  1. Boot using cd
  2. Mount existing ubuntu
  3. chroot to existing ubuntu
  4. apt-get install --reinstall findutils
  5. update-initramfs -u

This worked for me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.