Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Please help me upgrade my Ubuntu cause it's hard for me to update firefox and can't install Flash player. I tried the terminal but it didn't work.

share|improve this question

marked as duplicate by Thomas W., karel, minerz029, Seth, Avinash Raj Jan 13 at 11:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

4 Answers 4

You have a really old version of Ubuntu installed, which is already End of Life (EOL). Have a look here for upgrade to the current version. Need to be done in multiple upgrades.

Don't forget to do a backup before upgrading, if you have any data on your machine

share|improve this answer
add comment

I would seriously consider backing up your data and doing a clean install in your situation.

share|improve this answer
    
amen, it's better off to do a clean install than upgrade from an ancient version –  Sathya Jun 19 '12 at 9:26
1  
absolutely : as an aside while creating links like that looks pretty - I, for one, much prefer to see what a link is before hovering to check ;) –  Elfy Jun 19 '12 at 9:47
    
you're free to rollback changes; I won't edit such links from you then. To me makes more sense to know what a link is about & hover to find the actual link. But, personal tastes differ. –  Sathya Jun 19 '12 at 9:50
    
I'm not THAT worried :) –  Elfy Jun 19 '12 at 9:57
add comment

Try this in your terminal (ctrl+alt+t):

sudo apt-get dist-upgrade

If it does not help, what's displayed in a terminal?

share|improve this answer
add comment

Type the following in the terminal:

sudo apt-get dist-upgrade

It should automatically upgrade your Ubuntu installation.

share|improve this answer
2  
upgrade doesn't do dist-upgrades. –  hbdgaf Jun 19 '12 at 8:07
    
This does not actually resolve the issue at hand as it won't upgrade between overall versions. –  Stephen Michael Kellat Jan 12 at 23:05
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.