Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install Wine I get this fault

The following packages have unmet dependencies:

wine1.5: PreDepends: dpkg (>= 1.15.7.2~) but 1.16.1.2ubuntu7 is to be installed
         Depends: libc6 (>= 2.11) but 2.15-0ubuntu10 is to be installed
         Depends: wine1.5-i386 (= 1.5.6-0ubuntu1~pulse17) but 1.5.6-0ubuntu1~pulse17 is to be installed
share|improve this question
    
Just using Ubuntu 12.04 and Software Centre, you would have loaded wine 1.4-0ubuntu4. Where did you find wine1.5, and how did you install it? –  david6 Jun 19 '12 at 8:07
    
1.5 is available from the official ppa. it works fine for me. i suspect pinned packages –  hbdgaf Jun 19 '12 at 8:09
add comment

2 Answers

kamalesh. It seems that there's something wrong your software sources. Do you have PPA enabled on your machine? If so, try to do a ppa-purge to disable them and restore your repos to the orginal state. Please post your sources.list:

cat /etc/apt/sources.list

and I'll try to help you. Thank you.

Zhaofeng

share|improve this answer
    
I have the official ppa working fine here with wine 1.5. Just a note. –  hbdgaf Jun 19 '12 at 8:10
add comment

After downloading Wine 1.5.2 I had the same problem, but took the "safe" route. I opened Synaptic Package Manager and typed in each of the dependencies (one at a time, checking the box and then "Install"). It cleaned up the whole mess including autoconfiguration.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.