Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

EDIT: I've now gotten to the point where I can type in a boot line. I just need to know what to enter. Does anybody know what the default boot line for the Ubuntu Live CD is? After that I think I just need to add nomodeset and it should boot.

I'm attempting to install 12.04 on my computer but booting from my USB drive results in a blank screen. This has happened since 10.04 and has always been fixed by putting nomodeset in the boot command, but now I can't access the boot options with F6 for some reason. How can I access the boot options?

I booted into the live image on a different computer and it worked fine. I'm sure it's because of my Nvidia graphics.

When I boot into the live image it shows a small gray box in the lower left corner of the screen and that's it. I can't edit the boot options or do anything else.

Thanks in advance.

share|improve this question
1  
This thread is an excellent source for how to set boot options under a wide variety of circumstances. –  Eliah Kagan Jun 19 '12 at 4:43
1  
Thanks for the input. The splash screen / menu doesn't come up, though. So I can't get to the point to add nomodeset to the boot line. –  Ryan Kampmeier Jun 19 '12 at 5:20

4 Answers 4

As soon as you start to boot from the USB, hit any key and the Ubuntu Menu will come up...

enter image description here

If you press F6 you will get the other boot options (in the gray box in the corner) selecting one or more will append it to the boot command automatically. If nomodeset doesn't work the next one to try would be apci=off. After selecting the extra boot commands select "Try Ubuntu" and see if it will boot.

You are likely right about the problem being your Nvidia card but solving that problem is beyond me. I think I was able to answer you initial question at least.

share|improve this answer
    
Unfortunately, the initial splash screen doesn't show up. Pressing F6 at any point doesn't bring up a menu of any kind with 12.04. I'm trying to find a way to add nomodeset, it just seems impossible to get to the menu. Maybe editing a file on the USB if anyone knows of a file that contains the boot line? –  Ryan Kampmeier Jun 19 '12 at 5:19
    
If you can't get ANYTHING to come up and you have tested the md5sum and it works on another computer I would suspect that your computer is not supporting booting from the usb for some reason, or the usb port itself is faulty....do you have a optical disk drive on the problem computer? If so, can you boot from the live CD? Nvidia can cause problems but I've never heard of it never getting to the boot menu, only getting from the boot menu to the actual graphical desktop, even then I believe that your text only tty's will work... –  TrailRider Jun 20 '12 at 1:24
    
It turns out the little box in the corner was the menu. It's just a little gray box though. I can now get to the point where I can enter a boot command. Do you know what the default boot command is? That way I can add nomodeset and hopefully boot correctly. –  Ryan Kampmeier Jun 21 '12 at 3:02
    
If I understand you right, you can get the purple screen in the screen shot and pressing f6 gets the little gray menu to pop up? If so all you need to do is select nomodset and it will append it to the end of the boot command. When you then select the Try Ubuntu without Installing it will boot with the modified command. I do not know exactly what the boot command is it is the line you see in the screenshot that starts "Boot Options". The Boot Options line will only appear after pressing f6 –  TrailRider Jun 21 '12 at 3:29
    
I can get to a text only (black and white) terminal-esque menu. It says "boot: " If I press enter it attempts to boot and eventually tries to output something to the screen but then reverts back to a blank screen. If I enter "help" it brings up the F1 through F9 options. The problem is it doesn't supply me with a default boot command. That's why I need the entire default boot command. Then I can dump that in with nomodeset and hopefully be good to go. –  Ryan Kampmeier Jun 21 '12 at 3:38

Since you never see the initial splash screen, it's not behaving normally.

So it would be a good idea to MD5 test the .iso image you downloaded, to make sure it's not corrupted. (Normally I'd say to do "Check disc for defects" from the boot menu too ...but you can't get to the boot menu to select that.)

share|improve this answer
    
The MD5 test was good: ubuntu-12.04-desktop-amd64.iso: OK I guess I just have the worst possible hardware configuration for 12.04? Hopefully there is another step to take. –  Ryan Kampmeier Jun 19 '12 at 7:17

To add bootoptions, you could try editing syslinux/txt.cfg on the live USB. The file should look something like this, after adding the nomodeset option:

default live
label live
menu label ^Try Ubuntu without installing
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz nomodeset quiet splash --
label live-install
menu label ^Install Ubuntu
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
label check
menu label ^Check disc for defects
kernel /casper/vmlinuz
append noprompt boot=casper integrity-check initrd=/casper/initrd.lz quiet splash --
label memtest
menu label Test ^memory
kernel /install/mt86plus
label hd
menu label ^Boot from first hard disk
localboot 0x80

The relevant part is near the end of the fifth line, ...initrd.lz nomodeset quiet splash --.

You might also try removing the quiet splash -- part.

share|improve this answer

Personally, I use this Live USB software, works great. Worth givin it a try.

URL: http://unetbootin.sourceforge.net/

share|improve this answer
1  
The problem isn't getting the ISO to the usb drive, I have that covered. It's getting it to boot and display an image. Thanks for the comment though. –  Ryan Kampmeier Jun 19 '12 at 3:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.