Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, I want to bind two different keyboard keys to the system mute function. I go to system settings > keyboard > shortcuts > sound and media and find the Volume Mute setting and enter the second shortcut I want for it. However, this deletes the first shortcut. How can I bind two keys to this function?

share|improve this question
    
Take a look at this askubuntu.com/questions/73473/… –  Mitch Jun 19 '12 at 5:25
add comment

1 Answer

It is quite easy to do such a thing if you know the command for doing that function.
If you are using ALSA sound driver, the commands are :

amixer set Master mute` for muting the system

    "amixer set Master unmute" for unmuting the system  
    "amixer set Master toggle" for toggling volume.  
    "amixer set Master <vol>" to set volume level to <vol>

So, in the Keyboard shortcut option, click on Add and in the Command box, enter the functionality that you want.
Hope this helps.

share|improve this answer
    
None of those commands are working the same way as the existing command. Toggle will only turn the sound off but not back on. Mute just turns it off and unmute only turns it on. –  Jcubed Jun 19 '12 at 15:57
    
someone filed this bug bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/878986 –  piyush Jun 19 '12 at 16:03
    
How does the normal shortcut make it work then? –  Jcubed Jun 19 '12 at 16:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.