Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after installing 12.04 from 11.04 and using the gnome-fallback desktop I installed the CPU scaler app in the top bar. It shows that my laptop is always running in Performance mode and never goes to On-Demand shortly after bootup like it did in 11.04. I have to change it manually now. I am wondering if Performance is now standard in 12.04 or if the applet is just not working correctly. I honestly cant tell the difference in performance when I select either one and according to my temperature monitor there is no difference between the two either (Except that in On-Demand the CPU frequency changes between 800 Mhz and 2.27 Ghz) and in Performance it stays constantly at 2.27 Ghz). Powersave does make my laptop run cooler and slower as it stays at 800 Mhz. Has anyone else come across this at all? Thanks much for reading this.

share|improve this question

3 Answers 3

The ondemand governor is the default and best for most general use-cases. Incidentally, I ran some analysis on this for 12.04 to see how the governors shape up on different scenarios:

http://kernel.ubuntu.com/~cking/power-benchmarking/cpu-governor/results.txt http://kernel.ubuntu.com/~cking/power-benchmarking/cpu-governor/cpu-governors.ods

share|improve this answer
    
+1 for your research! As you can see with the very low difference in current between performance and powersave on idle, Intel's modern CPUs are really good at minimising power use on idle even when you force the CPU to run at full speed all the time. So speedstep is less necessary (but still helps). The same is not the case for the AMD Turion featured which sucks a lot more energy on performance when idle. –  neon_overload Jan 24 '13 at 0:54

The performance is normally set to ondemand, so it may be an issue with your system specifically, or it may be the way your CPU is set to work by default (a BIOS option most likely).

As you don't say what laptop you have, I can't give a detailed answer, but I would suggest checking the BIOS to see if it does not have the CPU set to a high performance mode.

share|improve this answer

Else you can try mercury. It may be helpful.

sudo add-apt-repository ppa:webupd8team/jupiter
sudo apt-get update
sudo apt-get install jupiter
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.