Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm attempting to install drivers for my GFORCE 610M and none of the solutions seems to work. Generally people recommend using the jockey-gtk program, which doesn't detect the card and states that there's no propitiatory drivers to install. I tried download the official binary from the NVIDIA site, but that told me that I had to remove the Nouveau kernal driver, so I did that, following the instructions on the wiki (apt-get remove --purge xorg-something or other) and ignoring the "DON'T DO THIS" warning, after that didn't do anything i installed various packages (nvidia-common, nvidia-settings, etc) and eventually got the nvidia-settings program (and a very low screen resolution). Unfortunately when I open nvidia-settings it tells me to run nvidia-xconfig as root (i've done this several times, but to no avail) and doesn't let me configure anything. At this point I tried re-running the binary installer i downloaded from nvidia's site, and it said it worked but it didn't change a thing. So I'm out of ideas, what've you got?

share|improve this question
    
Why do you want to install an additional driver anyway? Doesn't work without? –  jP_wanN Jun 20 '12 at 12:39
    
My main reason was that Gnome Shell looked like Gnome Classic due to lack of video drivers (I suspected, and have now confirmed), but also that games were simply unplayable –  thefinn93 Jun 20 '12 at 17:50

5 Answers 5

Have you tried going to "Additional Drivers", and activating the post-release updates? It contains the NVIDIA driver 295.49, I believe -- the one for that card.

share|improve this answer
    
No, where is that located? Additional Drivers just has Close, Help and a greyed out Enable button, looks like this –  thefinn93 Jun 19 '12 at 1:56
    
jockey-gtk and 'Additional Drivers" are the same thing. –  Dean Howell Jun 20 '12 at 18:01

Please go to the terminal and enter this command:

sudo apt-get install nvidia-current

This will install the proper driver for your hardware. When it is finished, please just restart and everything should work fine.

share|improve this answer
    
I tried that, it didn't work. I tried a ton of stuff and eventually messed my system up beyond repair (IMO), and reinstalled Ubuntu. –  thefinn93 Jun 20 '12 at 23:10
up vote 0 down vote accepted

Solved, but I had to do a full reinstall. On a clean copy of Ubuntu 12.04 desktop, following instruction on a page I can't find anymore I first purged the existing nvidia-current:

sudo apt-get purge nvidia-current

Then added the bumblebee repository:

sudo add-apt-repository ppa:bumblebee/stable

Then updated and installed bumblebee: sudo apt-get update && sudo apt-get install bumblebee bumblebee-nvidia

After a reboot everything worked nicely

share|improve this answer
    
If you have an nVidia optimus graphics card, you should have said that in the question. –  jP_wanN Jun 22 '12 at 7:17

if this is a problem for ubuntu read under :

to install nvidia gt 610m driver for ubuntu 12.10 :

first remove nvidai driver :

sudo apt-get remove nvidia-current && sudo apt-get remove nvidia-current-update

Then :

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update && sudo apt-get install nvidia-current nvidia-settings

For Ubuntu 12.04 or earlier :

sudo apt-get remove nvidia-current && sudo apt-get remove nvidia-current-update

Then :

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update && sudo apt-get install nvidia-current nvidia-settings

Good luck

share|improve this answer
    
You should try terminal commands as code rather than bold. It makes it much easier to read. –  Chris Wilson Nov 27 '12 at 12:19
    
Does this solution offer some way to switch on the GPU? From what I've heard that requires bumblebee at this point (see the solution I posted) –  thefinn93 Nov 27 '12 at 18:44

Bumblebee isn't the good driver for nVidia 610M

Best for list in the following link: LinuxSeason

I've installed it and my graphics card is an nVidia GT610M didn't work well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.