Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fresh install of ubuntu 12.04 server edition and mysql server is not starting properly.

I did a simple apt-get install

apt-get install mysql-server

But, it's failing with this error message

root@test:~# mysqld

120618 20:57:32 [Warning] The syntax '--log-slow-queries' is deprecated and will be removed in a future release. Please use '--slow-query-log'/'--slow-query-log-file' instead.

120618 20:57:32 [Note] Plugin 'FEDERATED' is disabled.

120618 20:57:32 InnoDB: The InnoDB memory heap is disabled

120618 20:57:32 InnoDB: Mutexes and rw_locks use GCC atomic builtins

120618 20:57:32 InnoDB: Compressed tables use zlib 1.2.3.4

120618 20:57:32 InnoDB: Unrecognized value fdatasync for innodb_flush_method

120618 20:57:32 [ERROR] Plugin 'InnoDB' init function returned error.

120618 20:57:32 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

120618 20:57:32 [ERROR] Unknown/unsupported storage engine: InnoDB

120618 20:57:32 [ERROR] Aborting

I can start the server with the "--skip-innodb --default-storage-engine=myisam" flags, but would like to use innodb.

Does anyone know what the issue here is?

share|improve this question
1  
Why are you trying to start it via mysqld rather than using the upstart script? I'd guess the upstart script does some configuration as well as it works OOTB for me. –  tgm4883 Jun 18 '12 at 21:21
add comment

2 Answers

up vote 1 down vote accepted

It was a configuration file issue. We are creating chef scripts to do deploys, and had used OpCode's mysql package, which did some very odd things that messed up Mysql on the machine that we had no expected, setting some configuration values to things that just didn't work.

If using chef, I advise to use the package available though apt-get

package "mysql-server" do
  action :install
end
package "mysql-client" do
  action :install
end

Then change the password through the code provided by OpCode, or changing it after the server install.

This was on Rackspace with Ubuntu 12.04 Server.

share|improve this answer
add comment

By default, MySQL should start automatically when you install it and then restart after a reboot; if not then you must have some configuration problems.

The mysqld command you're issuing isn't the usual way to start MySQL in Ubuntu, and could conflict with the normal setup: The recommended way to start/stop/restart is using the service command--eg mysql service restart--and it's also common to run the script at /etc/init.d/mysql, which you might see in older tutorials.

share|improve this answer
    
Yeah, I was just getting the stdout message, which was the same as sudo -u mysql mysqld. I haven't changed any configuration items, but things don't appear to be sane. I've apt-get removed all mysql items, then re-added to no avail. I've also tried apt-get removing, rm -rf /etc/mysql in attempts to let it give be the defaults... oddly to no avail. I'm wiping and starting again (unhappily). Will update. –  Rob Guderian Jun 19 '12 at 4:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.