Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to mount a ZFS drive to a Ubuntu 12.04 server installation. The drive is shared via NFS. I have installed ZFS for Linux but I still get a: wrong fs type, bad option, bad superblock error. Does anyone have any ideas.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

The reason you are getting that error is that you aren't trying to mount a ZFS share, you are trying to mount an NFS share. You shouldn't need ZFS installed on the linux machine. To mount it do

sudo mount example.hostname.com:/ubuntu /local/ubuntu

From https://help.ubuntu.com/12.04/serverguide/network-file-system.html#nfs-client-configuration

share|improve this answer
    
I did not have nfs-common installed. The sudo apt-get install nfs-common command solved the issue. Thank you for your help. –  Matt Jun 18 '12 at 21:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.