Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have boot-repair installed and it was working fine until one day I checked the option "Purge GRUB before reinstalling it" and went ahead and did what it said. But now, I tried to fix the GRUB and was off-line so I couldn't do it. Then I realized that the option "Purge GRUB before reinstalling it" is grayed, so I can't uncheck it. I purged boot-repair and reinstalled it but the problem continues. I've been thinking there's probably a configuration file I have to reset or delete so the option is available again.

share|improve this question
    
Have you tried to boot from a boot-repair CD? –  Mitch Jun 18 '12 at 20:15
    
Yes, I have. And I successful reinstalled the GRUB, but the problem I described persists. –  Mascaradeacero Jun 19 '12 at 21:53
    
Here's my BootInfo URL paste.ubuntu.com/1053015 –  Mascaradeacero Jun 21 '12 at 17:47
add comment

1 Answer

Boot-Repair's "Purge GRUB" option can't be unticked if some GRUB executables (eg grub-install) are missing in the system you want to repair. The "Purge GRUB" option will download the GRUB packages from Internet and reinstall them.

If you need more information, please indicate your BootInfo URL.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.