Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 LTS 64bit and a Huawei 366 broadband USB datastick. I can access the internet after manually turning it on from the menu, in 10.04 LTS I had it running automatically, but for some reason despite being in a 4G area, I get a connected to the gsm network message. Is there a way to get it to search for the faster network. I have already selected 3G preferred in connection settings. thanks

share|improve this question
add comment

1 Answer

Get this deb (but before you do browse the website to make sure it solves your problem and I'm not sure if it runs on 64 bit), http://mwconn.net/download_ixconn.html , then sudo dpkg -i ixconn.deb then sudo apt-get install -f to satisfy the dependencies (if any) .

On the first run you'll be required to configure , follow the instructions then go to network tab type in your APN, go to connection tab and check all in "Automaticlly" , go to monitoring then set "Display connection errors" to 0 and "Connection error tolerance" all to 0, on their website they say:

Please note: To allow a user to connect to the Internet, you may want to give him/her the necessary access rights. To do so, open System→System Administration→User and group accounts, then click on the key ring, select the user, klick on settings and check the two list entries whose names include the word "modem". logout then back in.

For this you'll need gnome system tools, why canonical removed it in precise is beyond me so we do :

sudo apt-get install gnome-system-tools

Now run ixconn and right click on the window and make sure "UMTS only" and "Connect automaticly" are checked.

If it connects to the internet but you cant browse the net , then one last thing you'll need to do is edit your resolv.conf file , back it up before editing. sudo gedit /etc/resolv.conf , change the nameserver to 8.8.8.8 or if you prefer opendns or what ever dns you use.

# Generated by NetworkManager

nameserver 8.8.8.8

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.