Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
jonquil@jonquil-Satellite-L755D:~/Downloads/akonadi-googledata-1.2.0/build$ cmake ..
-- The C compiler identification is GNU
-- The CXX compiler identification is unknown
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE):
  ERROR: cmake/modules/FindKDE4Internal.cmake not found in
  /home/jonquil/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
  CMakeLists.txt:6 (find_package)


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.8)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

With autotools I get this:

jonquil@jonquil-Satellite-L755D:~/Downloads/akonadi-googledata-1.2.0/build/build$ autoreconf -i -f
Can't exec "libtoolize": No such file or directory at /usr/bin/autoreconf line 196.
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 196.
autoreconf: `configure.ac' or `configure.in' is required
share|improve this question
    
what does which g++say? Obviously there is no working c++ compiler on the system. –  Thomas Jun 18 '12 at 17:34
    
It doesn't say anything. I have GCC installed if that helps. –  xjonquilx Jun 18 '12 at 17:52
add comment

2 Answers

Install build-essential Install build-essential if you haven't done so already. You can install it in the Software Center or with:

sudo apt-get update && sudo apt-get install build-essential
share|improve this answer
add comment

gcc does not contain g++, these are different packages. Install g++ Install g++:

apt-get install g++
share|improve this answer
    
Now I'm getting this: CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE): ERROR: cmake/modules/FindKDE4Internal.cmake not found in /home/jonquil/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/d‌​efault/share/apps;/usr/share/kde4/apps Call Stack (most recent call first): CMakeLists.txt:6 (find_package) –  xjonquilx Jun 18 '12 at 19:28
    
you are missing a build environment, it's more than just compilers, you need libraries and so on. Take a look here to find out what you need: help.ubuntu.com/community/CompilingEasyHowTo –  Thomas Jun 18 '12 at 19:39
    
I KNEW there was a package I could install in Ubuntu that would give me all the necessary packages for compiling, I just couldn't remember the name of it. Thanks! –  xjonquilx Jun 18 '12 at 19:50
    
I'm still getting the same error though. :( –  xjonquilx Jun 18 '12 at 19:51
    
The error messages hint's at kde - kde development is not included in build-essential. Don't know if there is a meta package for this. –  Thomas Jun 18 '12 at 20:00
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.