Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to remove Ubuntu 12.04 from my MacBook Pro. It's a trial boot system, with MacOS in the first partition, Windows 7 in the second one, and Ubuntu in the last. Now, I want to format this last one, in order to expand the Windows partition.

I tried to do this from MacOS, but I could not.

Everyone can help me, please? (when I insert the ubuntu live CD, after some initial boot screens, the command line says that it can't find the medium... It cannot see my ubuntu CD!)

share|improve this question

3 Answers 3

There are 2 ways to accomplish this. The easiest way is to boot from your Ubuntu Live CD or USB device.

Once the Ubuntu desktop has loaded, start Disk Utility (gparted).

Next, find your Ubuntu partion(s) and format them all as free space. Next, resize your Windows partition (NTFS) to consume the rest of the disk. Accept the operations and wait for a few moments.

That's it!

Good luck. :)

share|improve this answer
    
As I wrote in my first comment, I tried this, without lucky. Is there a way to format the partition from MacOS? –  VitoShadow Jun 18 '12 at 21:00

You could try to format it with an Ubuntu live CD.

share|improve this answer
    
It's exactly what I tried. But when I insert the CD, after some initial boot screens, the command line says that it can't find the medium... It cannot see my CD! –  VitoShadow Jun 18 '12 at 17:27
    
how did you install ubuntu then? –  jwd42 Jun 18 '12 at 17:33
    
have you tried this with an other linux distro, or an usb thumbdrive with ubuntu on it. –  jwd42 Jun 18 '12 at 18:04
    
did you press c before booting the live cd; becouse acording to this support page by apple:support.apple.com/kb/HT1533 you got to press c to boot from a cd. –  jwd42 Jun 18 '12 at 18:06
    
I installed the distro from the live CD. Now, I cannot use the same CD as a live distro... And this happens also when I try with an USB live... –  VitoShadow Jun 18 '12 at 20:59
up vote 0 down vote accepted

Ok, I solved. The problem was that I tried with a live CD of Ubuntu 10.04. After a lot of workarounds (for instance, I can boot from the live distro only if there are both CD and USB plugged in!), I solved using the Ubuntu 12.04 live CD, and gParted.

Thank you to everyone who wanted to help me!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.