Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed gpicview (to view pictures, as the name suggests). I want it to be the default image viewer program, but it is not listed in the application list (Right click on an image-> Properties-> Open with...). I also downloaded some programs (not in the repository), and I couldn’t find out how to associate them with a file type.

As I remember it, in some older versions of Ubuntu, there was an option "Browse...", and you could choose the programs you want to use. Is it still possible to do so now?

And I think the "Open with" function looks a bit clumsy, because it lists the same program several times (for some programs installed through Wine). Anyone knows how to fix it?

(I am using Ubuntu 12.04 now)

Edit: pcmanfm works fine in this case.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

What happens when you click "Show other applications"? That should show all installed apps and you should be able to select gpicview from there.

share|improve this answer
    
There are many programs listed, some repeated (Like Wine Internet Explorer, Wine hh), but not what I want (gpicview). Anyway, why should't we be able to browse for program like before? Or I have to install some additional software? –  Huynh Jun 18 '12 at 17:40
    
It seems that functionality has been removed from 12.04. I remember what you are talking about, but I haven't had a need to use it, so i never noticed the lack of it. However I also remember that Ubuntu Tweak has an option to set file type management, try giving that a go. –  boywithaxe Jun 18 '12 at 19:12
    
Thank you for your support, it suggested me to install some additional/alternative software, boywithaxe. I tried pcmanfm and it works great!. How to mark this thread as solved, I can't see the button? –  Huynh Jun 18 '12 at 23:58
    
I'm glad I helped. There should be a gray icon with a tick next to my first answer, clicking that will accept that answer as the solution for your issue. –  boywithaxe Jun 19 '12 at 9:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.