Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.04 64-bit installed DVD-RW recorder PATA as SCSI. My DVD-RW recorder is in /dev/sr0 as SCSI. I opened Disk Management and my IDE PATA drive is installed as SCSI. I can't use this drive because it hangs computer (I need to press reset button on CPU to get back to Ubuntu). What should i do to get the drive back to function correctly with the correct drive (IDE mode)? Also With the first(default) kernel version of the Ubuntu 12.04 64-bit , it was all functioning normally

Help me please.

share|improve this question
    
Did you tried booting from old kernel. And does the problem still exists from old kernel. –  atenz Jun 18 '12 at 17:54

1 Answer 1

I solved the problem removing the PATA DVD-RW Recorder and putting a SATA DVD-RW Recorder in my machine.

The IDE chipset of the my motherboard is VIA, and uses the pata_via module. I believe that this module is with some bug, because it register some devices as SCSI, and then they don't function properly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.