Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using my WiFi with no problem, but an hour ago I switched it off from system settings and then tried to turn it on again, but no success. It's about 1 month I am using it and I had no problem with WiFi except this one.

I rebooted and went to Windows 7, but even that OS can't turn it on. This is rfkill list all:

0: sony-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
1: sony-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: yes
2: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
share|improve this question
    
sudo rfkill unblock all. This command solved it. maybe not useful question! –  rastemoh Jun 18 '12 at 15:22
    
It is a usefull solution! Solver my problems –  jarondl Sep 17 '12 at 19:58
add comment

2 Answers 2

You've checked the switch for the wifi if there is one? Also look for a Fn Key combination that will enable it for you.

share|improve this answer
    
there is a key in the front side, but the On and Off states make no change. it also has a LED that turns on when WIFI is enabled, and it's off all the time whether I turn the key on or off. –  rastemoh Jun 18 '12 at 15:08
add comment

Enter you computer's BIOS and try "Load Setup Defaults" option to re-enable wireless. A few days ago, one of my friends had this problem and we solved it as I described to you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.