Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I want to replace windows with Ubuntu, so I installed it on my hard drive from a USB stick, but every time I try to install it, and when it gets done installing, i reboot the computer but all i get is a black screen with a small line(the line that marks where you are going to type), like its trying to boot from something but it cant find it (I've tried to install it about 10 times). I have tried to leave the black screen up for 30min to see if it would boot, but nothing. I tried to leave the live Ubuntu up all night to see if it was still installing, but nothing, nothing but that black screen. So can anyone help?

Computer info:

Hp pavilion 520n

Intell CPU @ 1.30GHz

520MB of RAM

share|improve this question
add comment

marked as duplicate by Eliah Kagan, Radu Rădeanu, Eric Carvalho, guntbert, Alaa Sep 2 '13 at 15:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

Just managed to solve this exact issue a moment ago.

After booting from the live CD and running boot-repair (sorry, I don't recall where I found the install instructions, Google should be able to help), it told me that my boot files were too far from the start of the disk, and that I should create a separate /boot partition at the beginning of the disk.

Installed GParted and used that to create a 200 MB partition at the beginning of the disk and toggled the boot flag to the new partition. Then in the advanced section of the boot-repair, there is an option to create a separate /boot partition. I pointed it at the new partition and let it do its thing.

After reboot, everything lights up as expected, no more blinking cursor.

share|improve this answer
add comment

Have you tried to boot in failsafe mode? When the machine starts up, hold down the left shift key until a menu appears. Select the failsafe boot, from there you will need to troubleshoot what type of video card you have an install the drivers for it so that it will display correctly for you.

share|improve this answer
    
I don't think that my computer has "failsafe mode" i held left shift and right shift and R/L CTRL and no menu poped up just gose to the black screen –  MrMDAN47 Jun 18 '12 at 22:23
add comment

First off, 520MB is an awfully small amount of ram, and pretty nonstandard too. Are you sure it isn't 512MB?

Secondly (to answer your question) the install iso you recieved may be corrupted, or the process of copying to files to the USB corrupted them.

Try redownloading the iso, using the same USB stick, and reinstalling. Failing that, try using a Live CD instead of a USB to install.

Hope this helps.

share|improve this answer
    
I have downloaded the iso files a lot and I've tried different methods to get them on the USB stick so i don't think that we don't have to worry about corrupted files. I've tried to boot from a cd and it just gives me this message: graphics initialisation failed Error setting up gfxboot boot: –  MrMDAN47 Jun 18 '12 at 22:39
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.