Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running Ubuntu 12.04, while in a terminal, I type ls and see list of folders, including the downloads folder. I then type cd downloads, press enter. I get

bash: cd: downloads: No such file or directory

I tried each folder, on two computers. What am I missing?

share|improve this question
add comment

3 Answers

Linux file and directory names are case-sensitive. The default name of download directory in Ubuntu is Downloads not downloads.

share|improve this answer
    
Probably a misunderstanding, rather than a blatant typo. –  Thomas W. Jun 18 '12 at 12:37
    
I just knew it would be something dumb! Many thanks –  Rich Dell Jun 18 '12 at 12:41
    
@RichDell You may want to accept this answer. –  Eliah Kagan Jun 18 '12 at 22:36
    
The answer seems perfect but we can also let the system indifferent to CASE setting the inputrc file, see answer below –  user3798 Jun 19 '12 at 17:37
add comment

In addiction to information about 'case-sensitivity' of linux system, make your bash case-insensitive setting right your ~/.inputrc

put this

set completion-ignore-case on

in your ~/.inputrc file, if file not exists create, after that make logoff, login and try:

cd dow<tab>

which corresponds to TAB

share|improve this answer
    
While making tab-completion case-sensitive is a great thing, It doesn not answer the question why the ls command in this case didn't work? –  Nanne Nov 3 '12 at 7:19
add comment

It should cd Downloads with a capital D.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.