Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Ubuntu Precise 12.04 LTS alongside with MS Windows 7 on my notebook Samsung 530U. I'm using both via dual-boot mode. I've no heating problem with MS Win 7 and the fan speed is normal even with long run utilization. However, when booting with Ubuntu and after short time, the PC got very hot and the fan was running at max speed. I installed a tool called Jupiter, I put it in "Power Saving" mode but no result.

Now, I avoid using ubuntu because I fear it'll damage my all new notebook.

share|improve this question
    
Please run lspci | grep vga in a terminal and post the result here. –  Web-E Jun 18 '12 at 10:56
    
I run it, but with no output ! –  Oualid Jun 18 '12 at 12:08
    
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) –  Oualid Jun 18 '12 at 13:21
    
here is your Final Fix. I managed to solve it by version 13.04 when it started in 12.04. Check this out askubuntu.com/a/321546/31571 –  whizzzkid Jul 18 '13 at 15:13
add comment

5 Answers

There can be many causes for overheating. The most common of which is Heatsink clogging.

Computer's heatsink can get clogged with dust and dirt. You may have to clean the heatsink of your computer. This can be done by blowing into the heatsink vent with compressed air or simply with your mouth. The other more comprehensive method is to completely dismantle your laptop and physically clean your heatsink. The procedure for cleaning varies from computer to computer and you can get it done from a Hardware guy if you are not confident of doing it yourself.

You can also consider buying a Cooling Pad ($10-$30) which can keep your computer cool.

Heating is also affected by the level of usage. Playing demanding games and using graphics editing software for extended time can generate greater levels of heat.

share|improve this answer
    
My notebook is all new !! I bought it only 02 months ago. –  Oualid Jun 18 '12 at 9:24
    
I see! In that case the most likely problem is incorrect/outdated drivers. –  upapilot Jun 18 '12 at 9:47
add comment

It might also be caused by the driver you're using for your graphics card.

My notebook has a ATI mobility card and if I use the wrong driver, the fan's constantly on at high speed (+ more heat and high battery dry for the obvious reasons).

So if you have a notebook with ATI card, this might be your issue: look for a better driver. (And don't use the "Post-release" driver offered by restricted-driver toolkit)

share|improve this answer
    
Thank you NicDM. Where can I find appropriate drivers? and can I install them? –  Oualid Jun 18 '12 at 9:31
    
Please tell us your ATI Radeon model no. so that we can point you to the appropriate drivers. –  upapilot Jun 18 '12 at 9:40
    
this is the result of : lspci | grep VGA : 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) –  Oualid Jun 18 '12 at 16:16
add comment

I often blow air through my laptop, and use a cooling pad, so I've upvoted upapilot's answer.

Some BIOS's supply incorrect or incomplete ACPI information, so you might try to get the BIOS handle the cooling itself. You do this with by editing /etc/default/grub and adding acpi=off to the line GRUB_CMDLINELINUX_DEFAULT between the quotes. Then run

sudo update-grub

It would be best to test this with an Ubuntu install CD first as it may make your system unbootable rather than resolving the problem. Booting Ubuntu from CD gives you an easy way to make this and several other settings when it boots Ubuntu from the CD.

You may also be able to interrupt GRUB when it presents its menu and select Ubuntu and press e for edit. Then add acpi=off at the end of the linux line. This adds the parameter just for that boot attempt. If it helps you can change it more permanently as above.

share|improve this answer
add comment

Try installing the cpu frequency indicator:

sudo apt-get install indicator-cpufreq

This will install an icon in the appmenu, here you can click and toggle your CPU to more conservative settings; see if this helps.

If there is no improvement, maybe check out this resource:

https://wiki.ubuntu.com/Kernel/PowerManagement

For example "Indicator-Weather" is problematic because it constantly writes to a log file, stopping the drive from becoming fully idle in power saving mode, causing heat, triggering fans, etc. This is mentioned in the research. Try to find apps that do this and uninstall them.

Good luck.

share|improve this answer
add comment

I Googled 'Ubuntu overheating laptop' and it is a HUGE problem. I fixed mine by installing Jupiter: http://itsfoss.com/install-jupiter-ubuntu-1304/ Keep in mind that this is an performance applet, so set the performance to 'power saving'. An alternative but may also be helpful is TLP found here under 'Improve battery life and reduce overheating' at the link at the end. Lastly you may want to check for graphics card updates or installing propriety drivers. Found here under 'Install additional drivers in Ubuntu 13.10' http://itsfoss.com/things-to-do-after-installing-ubuntu-13-10/.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.