Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just bought a new computer and installed Ubuntu 12.04 32-bit version.

After I enter my password, the screen freezes either at the login screen or with the ubuntu 12.04 LTS logo at the bottom. I rebooted with the reset button on my computer and it froze at a purple screen before even going to the login screen.

I think this is some problem with the graphics, but not 100% certain. When I assembled the computer at my friends house and used his monitor, everything worked just fine. The issue happened when I brought the computer home and used my Acer monitor. The computer has a DVI port and I use a DVI->VGA converter with a VGA cable.

When the login screen does appear, it starts from the middle of the screen and wraps around from the left. I did Ctrl+Alt+F1 and entered the terminal mode. I was able to successfully login from the terminal. So nothing is wrong with my files, maybe something with Unity. I did a "grep Failed /var/log/xorg.0.log" and it gave me a "Failed to load module "fglrx".

I tried to do sudo apt-get install fglrx but that didn't work because it couldn't find any files named fglrx. I did a locate fglrx and it did find some fglrx-desktop files.

Any thoughts? I maybe missing drivers needed for the Acer monitor, but I don't know how to install drivers in Ubuntu. I have:

Acer S232HL LCD monitor
Asus Radeon HD 6670 graphics card
Intel Core i7 processor

Edit: I found out that I don't have any fglrx installed on my system, except for


It seems that several attempts are being made to load some driver:

$ grep "autoconfigured driver" /var/log/Xorg.0.log
[ 9.937] (==) Matched fglrx as autoconfigured driver 0
[ 9.937] (==) Matched ati as autoconfigured driver 1
[ 9.937] (==) Matched vesa as autoconfigured driver 2
[ 9.937] (==) Matched fbdev as autoconfigured driver 3

But the only available drivers are the following:

$ grep drivers /var/log/Xorg.0.log
[ 15.459] (II) Loading /usr/lib/xorg/modules/drivers/
[ 15.466] (II) Loading /usr/lib/xorg/modules/drivers/
[ 15.481] (II) Loading /usr/lib/xorg/modules/drivers/
[ 15.482] (II) Loading /usr/lib/xorg/modules/drivers/
[ 15.492] (II) Loading /usr/lib/xorg/modules/drivers/
[ 15.492] (II) Loading /usr/lib/xorg/modules/drivers/
[ 15.492] (II) Loading /usr/lib/xorg/modules/drivers/
[ 15.494] (II) Loading /usr/lib/xorg/modules/drivers/

Also, I found this great troubleshooting guide and followed their instructions in "Problem: Video card not supported by driver"

$ lspci -nn | grep VGA
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Turks [Radeon HD 6670] [1002:6758]

But running grep -i 10026758 /usr/share/xserver-xorg/pci/*.ids gave me nothing.

I do have a file named /usr/share/xserver-xorg/pci/geode.ids, but it has no PCI ID 1002:6758.

Also, I don't have any file named /etc/X11/xorg.conf. I don't understand where exactly the problem is. It maybe that the X server can't find 1002:6758 in geode.ids and defaults to vesa. Is there a way to obtain the correct .ids file? Or should I download new AMD Catalyst Display Drivers (fglrx) from the AMD website?

share|improve this question

The following Instructions below explain how install the latest ATI Catalyst Video driver on a fresh install of Ubuntu 12.04 Precise. Please follow these commands...

Step 1

Download Latest driver from here.

Create a folder name Catalyst in desktop and put the downloaded file in there.

Step 2

Open a terminal and type:

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
sudo rm /etc/X11/xorg.conf
sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 xserver-xorg-core
dpkg-reconfigure xserver-xorg
sudo reboot

After reboot, open a terminal and type:

cd ~/Desktop
cd Catalyst
sudo sh amd-driver-installer-*.run --buildpkg Ubuntu/precise

This will creat 3 .deb package in that following directory. Then, type:

sudo dpkg -i *.*deb

This will install this package in your machine. If any error occurred type sudo apt-get -f install. It will fix dependency problem. Then again install these package by typing sudo dpkg -i *.*deb.

If you don't get error in second time then you are good to go. Type:

sudo amdconfig --initial -f
sudo reboot

After reboot check with:


You will see like this:

display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Mobility Radeon HD 6000 Series 
OpenGL version string: 3.3.11631 Compatibility Profile Context
share|improve this answer

When you can't find a package you believe exists, the first thing to do is search for it here.

These search results reveal the package exists and is provided in the restricted component.

First, run:

sudo apt-get update

This updates your Ubuntu system's local database of what packages and versions are available for installation and where they can be obtained.

Then try this again:

sudo apt-get install fglrx

(You should always run sudo apt-get update before running sudo apt-get install ..., unless you have run sudo apt-get update very recently.)

If that doesn't work, open the Software Sources window. (One way to do this is to open the Update Manager and click the Settings... button at the lower-left corner of the window.)

Software Sources window, showing the Ubuntu Software tab

In the Ubuntu Software tab, under Downloadable from the Internet, make sure Proprietary drivers for devices (restricted) is checked. Then click Close.

Then, in the Terminal, try installing fglrx again:

sudo apt-get update
sudo apt-get install fglrx

By the way, you should also be able to install this and any other proprietary drivers in Additional Drivers, though occasionally there is a driver that will work on your system, and is provided by official Software Sources in Ubuntu, but isn't listed there.

share|improve this answer
Thank you for your reply! It turned out that I had to do a lot of upgrades since I had bought a new computer. I did "sudo apt-get update", "sudo apt-get upgrade", and "sudo apt-get install fglrx". I was finally able to login and get to the Ubuntu Desktop without having to do Ctrl+Alt+F1. – gmcoffee Jun 19 '12 at 7:18

I believe your problem is with your Radeon card. fglrx is in the repositories and if you aren't able to install it then you may not have any network connectivity.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.