Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to start some games from the sidebar, their icon just glows a few times and then stops. I've tried if with the following games and they don't seem to work:

I have tried: Licity-NG, Supertuxcart, Stellarium, ect.

share|improve this question

closed as too localized by Javier Rivera, RolandiXor, belacqua, jokerdino, ajmitch Aug 18 '12 at 8:04

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You should report this as a bug in unity. –  Eliah Kagan Jun 18 '12 at 2:59
    
I've edited to reflect what you've actually posted. The first rev sounded like you couldn't launch anything but the post reveals it's just a few games/3D stuff. Can you run the applications from the terminal and post the output. That way we can see the output and suggest a proper fix. –  Oli Jun 18 '12 at 3:01
    
I think this is a bug, because I also got this problem. –  Emerson Hsieh Jun 18 '12 at 3:20
    
Does the application open when you start it from terminal? Can you investigate the command used to run it, it should be the Exec= line in the .desktop file, found in /usr/share/applications. –  NoBugs Jun 18 '12 at 5:51
add comment

1 Answer 1

We had a similar issue with our app. Turns out that we use a wrapper to launch it - and it cannot be launched without the wrapper.

However, the icon in the tray is the app's icon, not the launcher's icon.

Removing the & from the launcher solved the problem, since now it's the wrapper's icon that we see.

As to why it cannot be launched without the wrapper? Seems that the app looks for its config files using a relative path - and the icon in the launcher confuses it; it thinks it's located in the launcher.

As to your question: Maybe you can figure out how to add the original icons to the launcher, without launching the apps. (Though you probabaly will then have 2 icons displaying while the app is running.)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.